NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Search strings in regexp mode are not remembered


Joined: 10 Sep 2013
Posts: 9
Reply with quote
Nusphere 17 build 17016.

Case:
1. Open "Find and Replace" dialog (I guess Ctrl+H or Ctrl+R but I may have set my own hotkeys).
2. Enter anything in "Text to find"
3. Tick on "Regular expressions" checkbox
4. Click "Replace All"
5. Open the dialog again and look for previously searched strings.

The text you have searched does not appear there at the top.

If you uncheck "Regular expressions" - it is remembered
If you click "Ok" instead of "Replace All" - it is remembered
If you open the Search dialog (Ctrl+F) and do the same then both searches by clicking "Ok" and "Mark all" remember it.

Looks like a bug to me and rather frustrating one especially when you figured you got the initial regexp wrong. Unless it was specifically designed in this way.
View user's profileFind all posts by ruslanbesSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7835
Reply with quote
I tried and didn't reproduce. You need to contact support.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Search strings in regexp mode are not remembered
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic