NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[PhpED 6] - Search in Files does not work on network drive


Joined: 14 Sep 2010
Posts: 18
Reply with quote
(build 6026)


  • Search > "Search in Files" does not work when the Project is located on a mapped network drive (Windows 7 x64, Windows XP)
  • I got this error when opening a file: IDE Access violation at address 005A05FD in module 'phped.exe'. Read of address 00000008 (although it did successfully open the file)


Last edited by hurrakan on Thu Jun 09, 2011 8:03 am; edited 11 times in total
View user's profileFind all posts by hurrakanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
I'm not sure what you edited 11 times in your short post. Hope you were trying to find correct words describing your problem.
Anyway, it does not work this way here.
Please submit an accurate report using http://www.nusphere.com/contact_us form and provide all the details upon support reply.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 14 Sep 2010
Posts: 18
Reply with quote
dmitri wrote:
I'm not sure what you edited 11 times in your short post. Hope you were trying to find correct words describing your problem.
Anyway, it does not work this way here.
Please submit an accurate report using http://www.nusphere.com/contact_us form and provide all the details upon support reply.

Submitting a bug report there was the first thing I did (NU SUPPORT #UEK-848676).

I'm sorry but I don't understand what you mean by "it does not work this way here.". Can you please clarify?

Why have the posts from other users who also experienced this problem been deleted, along with my other posts providing more details?
View user's profileFind all posts by hurrakanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
According to UEK-848676:
Posted on: 08 Jun 2011 5:24 AM
1st nusphere support reply: Posted on: 08 Jun 2011 10:29 PM
your followup: Posted on: 09 Jun 2011 4:00 AM
2nd nusphere support reply: Posted on: 09 Jun 2011 7:54 AM
your reply: Posted on: 09 Jun 2011 8:12 AM
your reply: Posted on: 09 Jun 2011 8:12 AM
3rd nusphere support reply: Posted on: 12 Jun 2011 8:54 PM
your reply: Posted on: 13 Jun 2011 5:12 AM
4th nusphere support reply: Posted on: 13 Jun 2011 10:48 PM
your reply: Posted on: 14 Jun 2011 5:00 AM
5th nusphere support reply: Posted on: 15 Jun 2011 10:08 PM
so it looks like our support is waiting for your reply

As of the rules on this forum -- they are posted in this sticky http://forum.nusphere.com/the-rules-please-read-this-first-before-making-a-post-t744.html and you confirmed that you understand and agree with them when signed up to this forum
(same goes to the other people who bashed here with this problem)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 14 Sep 2010
Posts: 18
Reply with quote
dmitri wrote:
According to UEK-848676:
Posted on: 08 Jun 2011 5:24 AM
1st nusphere support reply: Posted on: 08 Jun 2011 10:29 PM
your followup: Posted on: 09 Jun 2011 4:00 AM
2nd nusphere support reply: Posted on: 09 Jun 2011 7:54 AM
your reply: Posted on: 09 Jun 2011 8:12 AM
your reply: Posted on: 09 Jun 2011 8:12 AM
3rd nusphere support reply: Posted on: 12 Jun 2011 8:54 PM
your reply: Posted on: 13 Jun 2011 5:12 AM
4th nusphere support reply: Posted on: 13 Jun 2011 10:48 PM
your reply: Posted on: 14 Jun 2011 5:00 AM
5th nusphere support reply: Posted on: 15 Jun 2011 10:08 PM
so it looks like our support is waiting for your reply

As of the rules on this forum -- they are posted in this sticky http://forum.nusphere.com/the-rules-please-read-this-first-before-making-a-post-t744.html and you confirmed that you understand and agree with them when signed up to this forum
(same goes to the other people who bashed here with this problem)


Thanks , I had just checked the rules before I saw your reply and I realised that users are not meant to post "technical problems and bugs", so sorry about that.
However, that rule (#3) seems to contradict the forum description: "Get help with installation and running phpED for Windows here.".

I only supplied the ticket id because you seemed to doubt that I had submitted one. Now you seem to be attacking for me not replying yet... (?!) I will reply when I finish work and arrive home where I can try to reproduce the bug on my home computer so that I can provider more details to the tech. support team (as they requested).

Also I have never "bashed" Nusphere PhpED (neither in this thread or anywhere else) - if you like I can post links to the Google cache of this thread.

I've been a very loyal customer for years and I always recommend PhpED to other developers.

Your tone comes across as aggressive and unprofessional.


Last edited by hurrakan on Thu Jun 16, 2011 8:53 am; edited 2 times in total
View user's profileFind all posts by hurrakanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
you asked what happened to the other people posted their reports in this same theread Smile
word "bashed" related to some impatient users.

and no, I didn't mean to attack anybody. Fill free to reply whenever you decide appropriate.
Also please supply details -- whether the problem happens with any Windows Share available to you or with some (only one?) particuar.
I tried many combinations -- Windows2003 server share, Mac OSX SMB share, ssh-tunneled Windows share -- all are working fine for me, no problems with Search so far.
It looks like something special happens in your case, like SMB was disconnected (for some reason) or was not connected. In W7 it works slitly different than for example under XP.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Guru master

Joined: 24 Jul 2009
Posts: 712
Reply with quote
Hi Dimitri, I can confirm that I also have this issue. Windows Vista x64 accessing a file share \\xxxx\c$\inetpub\apache_htdocs\sitename\ on a Windows 2003 Server, using either a UNC or a mapped drive letter.

Both UNC and mapped drive letter seem to work fine with PhpED except search in files flashes through the files in the dialog, possibly much too fast to be actually reading them, and never finds anything. Even right-clicking a single file in the Explorer and doing a search in file on the single file will never find anything.

Copying the files to a local drive then searching work fine.

I've also tried it on Windows Vista x64 (different computer to same share) and that also did not work.

I'm not yet using 6028 for real work, but I can install it in a Windows Vista 32-bit and Windows XP 32-bit just to see if that behaves any differently. I think I've got just about every version of Windows here. Smile But that will be tomorrow, as it is current 2:15am here and about time I finished for the day.

Just found a possible clue for you.

If I search a local drive, the search dialog shows the Directory and Searching shows the file name.

If I search a network share, the Directory is shown but Searching stays blank; it looks like it finds directories but not files.

So I just did a sysinternals procmon and whilst using a mapped drive I can see PhpED doing the following on each directory:

Code:
474   2:25:08.4375183 a.m.   phped.exe   10028   QueryStandardInformationFile   \\server\c$\Inetpub\apache_htdocs\12all..local\ac_global   SUCCESS   AllocationSize: 0, EndOfFile: 0, NumberOfLinks: 1, DeletePending: False, Directory: True   6808
475   2:25:08.4385521 a.m.   phped.exe   10028   QueryDirectory   \\server\c$\Inetpub\apache_htdocs\12all..local\ac_global\*   SUCCESS   Filter: *, 1: .   6808
476   2:25:08.4395921 a.m.   phped.exe   10028   QueryDirectory   \\server\c$\Inetpub\apache_htdocs\12all..local\ac_global   SUCCESS   0: .., 1: activerecord, 2: amcolumn, 3: amline, 4: ampie, 5: amradar, 6: amxy, 7: api, 8: authlib, 9: charts, 10: classes, 11: context, 12: cpaint, 13: css, 14: editor_tiny, 15: ezpdf, 16: functions, 17: includes, 18: js, 19: jscalendar, 20: loginsource, 21: media, 22: menu, 23: pclzip, 24: pear, 25: ReadMe.txt, 26: really, 27: scriptaculous, 28: scripts, 29: smarty, 30: smarty_plugins, 31: swiftmailer, 32: templates, 33: tools, 34: xml_parser   6808
477   2:25:08.4396758 a.m.   phped.exe   10028   QueryDirectory   \\server\c$\Inetpub\apache_htdocs\12all..local\ac_global   NO MORE FILES      6808
478   2:25:08.4397279 a.m.   phped.exe   10028   CloseFile   \\server\c$\Inetpub\apache_htdocs\12all..local\ac_global   SUCCESS      6808


And with a local directory I see:

Code:
374   2:29:15.5603901 a.m.   phped.exe   10028   CreateFile   G:\12all..local\ac_global   SUCCESS   Desired Access: Read Data/List Directory, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened   6808
375   2:29:15.5604248 a.m.   phped.exe   10028   QueryDirectory   G:\12all..local\ac_global\*   SUCCESS   Filter: *, 1: .   6808
376   2:29:15.5604648 a.m.   phped.exe   10028   QueryDirectory   G:\12all..local\ac_global   SUCCESS   0: .., 1: activerecord, 2: amcolumn, 3: amline, 4: ampie, 5: amradar, 6: amxy, 7: api, 8: authlib, 9: charts, 10: classes, 11: context, 12: cpaint, 13: css, 14: editor_tiny, 15: ezpdf, 16: functions, 17: includes, 18: js, 19: jscalendar, 20: loginsource, 21: media, 22: menu, 23: pclzip, 24: pear, 25: ReadMe.txt, 26: really, 27: scriptaculous, 28: scripts, 29: smarty, 30: smarty_plugins, 31: swiftmailer, 32: templates, 33: tools, 34: xml_parser   6808
377   2:29:15.5607191 a.m.   phped.exe   10028   QueryOpen   G:\12all..local\ac_global\ReadMe.txt   SUCCESS   CreationTime: 9/06/2011 8:33:39 p.m., LastAccessTime: 9/06/2011 8:33:39 p.m., LastWriteTime: 2/07/2010 12:26:12 p.m., ChangeTime: 9/06/2011 8:33:39 p.m., AllocationSize: 4,096, EndOfFile: 101, FileAttributes: A   6808
378   2:29:15.5608043 a.m.   phped.exe   10028   CreateFile   G:\12all..local\ac_global   SUCCESS   Desired Access: Read Data/List Directory, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened   6808
379   2:29:15.5608344 a.m.   phped.exe   10028   QueryDirectory   G:\12all..local\ac_global\ReadMe.txt   SUCCESS   Filter: ReadMe.txt, 1: ReadMe.txt   6808
380   2:29:15.5608631 a.m.   phped.exe   10028   CloseFile   G:\12all..local\ac_global   SUCCESS      6808
(then goes through the rest of the files)


So it appears that on a network share, once the list of sub-directories has been read from a directory, it is getting a NO MORE FILES status.
View user's profileFind all posts by plugnplaySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Sorry, posting the problem-details on this forum makes pretty little sense. This is not a support channel. Please use http://www.nusphere.com/contact_us to create a ticket and submit all the details here.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 14 Sep 2010
Posts: 18
Reply with quote
dmitri wrote:
Sorry, posting the problem-details on this forum makes pretty little sense. This is not a support channel. Please use http://www.nusphere.com/contact_us to create a ticket and submit all the details here.

A bug-tracker might be a better solution, as it allows users to share details (and ideas) that might help to debug the problem more quickly. Just a suggestion.
View user's profileFind all posts by hurrakanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Right and we use bugtracker, but it's available to betatesters and maintainers only.
Honestly, there are little errors in PhpED almost all the time between the releases, so making bugtracker public and maintaing the results is not so practicable. I believe helpdesk works better for the customers.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Mar 2010
Posts: 28
Reply with quote
Same Problem ... and I can't understand that this hasn't been detected during Beta testing Process ... Who are those Beta Testers?
View user's profileFind all posts by eutychusSend private message


Joined: 06 Aug 2007
Posts: 12
Reply with quote
eutychus wrote:
Who are those Beta Testers?

As you can see it's you, me and other users of PhpED Wink
View user's profileFind all posts by shimasoftSend private message
[PhpED 6] - Search in Files does not work on network drive
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic