NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
*RESOLVED* DB Client "Could not connect"


Joined: 12 Aug 2009
Posts: 3
Reply with quote
* Resolved *Hi
I am getting a could not connect message using phpED, Any pointers?

Quote:
Cound not connect using: root@serverIP
2003 - Can't connect to MySQL server on 'serverIP'(10060)


Root user in mySQL is definded as root@%

Not sure if this would interfer.. but here is some information from phpmyadmin

Quote:
Microsoft-IIS/7.0
MySQL client version: 5.0.51a
PHP extension: mysqli


Thoughts Question


Last edited by jlanders on Fri Sep 25, 2009 11:05 am; edited 1 time in total
View user's profileFind all posts by jlandersSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8246
Reply with quote
I can think of 3 possible problems that will result in 10060 network error:
-either client (php.exe, SRV, php-cgi.exe, Apache?) or mysql server itself or both are firewalled (hence check the firewall settings and add appropriate permissions)
-wrong port (check the ports)
-wrong IP address (check the address)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 09 Jul 2009
Posts: 13
Reply with quote
A few notes to keep in mind

1. You should never write an application that requires you to connect to the database as root (but that's really just a security thing).
2. Permissions of '%' cover all remote IP addresses. If you are trying to connect locally (through 'localhost' or '127.0.0.1') you will need to specify a separate permissions item for root@'localhost' (This has always been the case for my servers, anyway)
View user's profileFind all posts by killermonkSend private message
*fixed*


Joined: 12 Aug 2009
Posts: 3
Reply with quote
It has been a while since I had visited this post. I struggled with this for some time. I changed database permissions, added different users. I think I tried all of the database access options I could think of. Nothing worked. I preceeded to get crazy and started swapping out the libmysql.dll.

*Important saftey tip* We all know that we should make copies of good files before we overwrite them with different versions. Do your self a favor and don't skip this step like I did. Life is miserable if you do... I changing versions of mysql. Nothing worked. So I gave up.

Dmitri's response came in and I looked it over and one bored morning I went back and listened.


I changed all the firewall prots as he indicted. I am runing all of this on Windows 2008 as 3rd part mode. I saw a firewall rule in there for MySQL. So being in a hurry I assumed it covered everything. I was wrong. I make the exceptions Dmitri indicated for the apps. Then I added an exception for 3306. Testing it again I got a client connection error. I then made a copy of the current libmysql.dll and copied the dll from the bin directory from my mySQL server. It popped right up.

Thank you for your responses Killer and Dmitri. any response is valuable!!

This is a closed issue.
View user's profileFind all posts by jlandersSend private message


Joined: 21 Sep 2009
Posts: 12
Location: New Zealand
Reply with quote
I had a issue as well and MySQL server was using the system temp directory as temporary storage for session data. However something was protecting the files as read only every so often.
I moved the temp folder via the my.ini file and never had an issue again. This was a windows system I was using as development.
View user's profileFind all posts by veldthuiSend private message
*RESOLVED* DB Client "Could not connect"
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic