NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Profiler data missing every 2nd request


Joined: 04 Dec 2013
Posts: 1
Reply with quote
Hello,

whenever I profile code with debug session enabled profiler data is missing for every second request I make.
SQL profiling works, but nothing else.
I did some short research and it seems like the DBGSESSID value is not handled properly.

1st request (profiling ok):
Code:
GET /test/ HTTP/1.1
Host: localhost
Connection: keep-alive
Cache-Control: max-age=0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36
Accept-Encoding: gzip,deflate,sdch
Accept-Language: de-DE,de;q=0.8,en-US;q=0.6,en;q=0.4
Cookie: DBGSESSID=1%3Bd%3D0%2Cp%3D17%2Cc%3D1


1st response:
Code:
HTTP/1.1 200 OK
Date: Thu, 05 Dec 2013 20:50:53 GMT
Server: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
X-Powered-By: PHP/5.4.7
Set-Cookie: DBGSESSID=1%3Bd%3D0%2Cp%3D145%2Cc%3D1; path=/; version=1
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 513
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Content-Type: text/html;charset=ISO-8859-15


2nd request (profiling fails):
Code:
GET /test/ HTTP/1.1
Host: localhost
Connection: keep-alive
Cache-Control: max-age=0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36
Accept-Encoding: gzip,deflate,sdch
Accept-Language: de-DE,de;q=0.8,en-US;q=0.6,en;q=0.4
Cookie: DBGSESSID=1%3Bd%3D0%2Cp%3D145%2Cc%3D1


2nd response:
Code:
HTTP/1.1 200 OK
Date: Thu, 05 Dec 2013 21:00:32 GMT
Server: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
X-Powered-By: PHP/5.4.7
Set-Cookie: DBGSESSID=1%3Bd%3D0%2Cp%3D17%2Cc%3D1; path=/; version=1
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 513
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html;charset=ISO-8859-15



As you can see the D parameter is changed from 17 to 145 which then results in missing profiler data for the next request.
The other way, when D=145 is sent, it is changed to 17...

I'm running dbg-5.0.8 for php 5.4 windows and php 5.1 linux.

How can I solve that?
View user's profileFind all posts by pladuxSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
First of all, dbg-5.0.8 was released in Feb 2013 and there are at least 3 updates we released for this version since that time.
With PhpED v11 and v12, we ship dbg-6.0 and it's dbg-6.0.12 now.
Seems you have to update.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Profiler data missing every 2nd request
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic