NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
port 7869 not open


Joined: 05 Jul 2004
Posts: 1
Reply with quote
i installed dbg successfully. and the result of phpinfo() contains
Code:
This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies with DBG v2.11.26, (C) 2000,2001,2002,2003, by Dmitri Dmitrienko

and
dbg
DBG php debugger, version 2.11.26, Copyright 2001, 2002, Dmitri Dmitrienko, www.nusphere.com/dbg

Version 2.11.26
Linked as a shared library.
Profiler not compiled

Directive Local Value Master Value
debugger.enable_session_cookie On On
debugger.enabled On On
debugger.fail_silently On On
debugger.ignore_nops Off Off
debugger.JIT_enabled Off Off
debugger.JIT_host clienthost clienthost
debugger.JIT_level 3 3
debugger.JIT_port 7869 7869
debugger.profiler_enabled On On
debugger.session_nocache On On
debugger.timeout_seconds 300 300

but i used "netstat -an", there is no port 7869 opened.

i founed this in the result of phpinfo():
--disable-debug
does this has something to do with my problem?
View user's profileFind all posts by stoSend private message
RE: port 7869 not open


Joined: 17 Jul 2004
Posts: 1
Reply with quote
Dear,

I had the same problem and I had found the answer.

Go to your php.ini and change the line like this:
debugger.hosts_deny = None
or add you’re local IP address after debugger.hosts_allow = 10.0.0.12

After you do this, restart PhpEd and make sure that the PHP DBG listener was stopped.

Sincerely,
Eddy
View user's profileFind all posts by morisoftSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
First of all,
debugger.hosts_allow, debugger.hosts_deny, debugger.ports are supported by commercial version of phped while noted version 2.11.x is a free one and therefore just ignores these settings.
Secondly,
Dbg does never open any listending sockets and therefore netstat -an would never show them too. It's DbgListener opens such sockets and Dbg module just connects to them.
Thirdly,
--disable-debug relates to debugging php engine core itself. You don't need it enabled unless you want to develop php engine or investigate its problems.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
port 7869 not open
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic