NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Please improve tabbing!!!!


Joined: 18 Sep 2003
Posts: 17
Location: Fl
Reply with quote
See MS VC editor for working example.

If below is the tab scheme:

.....x.....x.....x (tab stops)

Then:

a...bb....x.....x

adding adding another 'a' after the first will NOT move the bb's position. Got it?

This small change will make a BIG difference in ease of editing/formatting.

Thanks,
Zany Dog
View user's profileFind all posts by Zany DogSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Naturally, I dot't get you.
Could you please denote tabs and spaces (if any) with some symbols, for example tab with x and space with dot (.) ? Then please show me what was typed in the editor before, what you typed, what you got as a result and what you expected to get.

Thanks.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Sep 2003
Posts: 17
Location: Fl
Reply with quote
Quote:
with some symbols, for example tab with x and space with dot (.) ?


Yeah, that's exactly what I was using. Smile But to explain another way:

Before:
a...b..... ( the 'b' is in column 5 - first tab stop)

Now we will add another 'a' right after the first one

Here's how it works now:
aa...b..... (the 'b' moves forward one to column 6, one past the first tab stop)

Here's how it should work:
aa..b..... (after the 'a' is typed the 'b' STAYS in the same position, column 5, the first tab stop)


Hope that makes since. If you have MS VC, .net, or Dreamweaver (and I'm sure a lot of others), you can test it there, as this is exactly how it works. Try formatting some code in it, you will see what a difference it makes.

Thanks,
Zany Dog
View user's profileFind all posts by Zany DogSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
If you entered spaces between a and b, I don't known any editor that would correct number of spaces. If you entered tab symbol, you'd get behaviour exactly as you described. Don't forget to check "use tab character" in the settings for the editor. Otherwise phped inserts spaces.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Sep 2003
Posts: 17
Location: Fl
Reply with quote
Quote:
Don't forget to check "use tab character" in the settings for the editor.


Embarassed ummmm. ok that was easy. Didn't there was an option for it. Now it works as mentioned above. Wish I had known about that earlier!

I guess my only other suggestion, would be to have it default to on for dummies like me.

Thanks!
Zany Dog
View user's profileFind all posts by Zany DogSend private messageVisit poster's website
Tabs


Joined: 17 Sep 2003
Posts: 6
Reply with quote
Yes I agree! I was really getting ticked off at the tab feature until I found this post and now it works as expected.

The DEFAULT should be ON (tab char) because if I hit tab, I WANT A TAB NOT A BUNCH SPACES!! Otherwise I'd hit space bar a couple of times

Wink
View user's profileFind all posts by hecktarzuliSend private message
Guest


Reply with quote
Still defaults to OFF.


Joined: 09 Dec 2003
Posts: 92
Reply with quote
Well, on the other hand you might say that "off" is a reasonable default. E. g. the PEAR project coding standards (http://pear.sourceforge.net/en/standards.php) require you NOT to use the tab character.
View user's profileFind all posts by mpSend private message
Please improve tabbing!!!!
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic