NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHPUnit debugging doesn't show the blue current line
Veteran

Joined: 30 Aug 2006
Posts: 116
Reply with quote
I have a weird situation. I have debugging working fine and have been using it for many years without problems. Recently we are switching to PHPunit for our unit tests, and debugging of phpunit invocations seems to behave strangely.

Here's what I'm observing:


  1. I am triggering using DebugBreak('1@host');
  2. Debug starts, there's no warnings about mappings and mappings have been setup for the project.
  3. HOWEVER, the blue line never shows up, and the file opens but not to the line in which the DebugBreak is found.
  4. As you use F8 and F9 to navigate the debug you never ever see the blue line, and you can never tell where you are during the debug, but the Watchlist is populating and changing, so the code is properly walking through each line.
  5. Even more weird, EVERY time the debug starts a new copy of each file is opened, yet again, this is not the same as when it opens an unmapped file, there is no Unmapped File label in the heading of the file.


Anyone know what's going on, or have any suggestions? I'm running PHPEd 6.1 Buld 6106.[list=][/list]
View user's profileFind all posts by rudderSend private message
Veteran

Joined: 30 Aug 2006
Posts: 116
Reply with quote
I sent a support request through the customer portal and have not heard a thing back. I really need some support here with this. Perhaps I'm not receiving the replies?
View user's profileFind all posts by rudderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
the ticket was answered,
perhaps, you have to check your mail server

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 30 Aug 2006
Posts: 116
Reply with quote
Hi dmitri,

I checked my spam and everything and I cannot find any emails that contain the words "nusphere" or "phped" since Jul 2011.

I'm using gmail, so there's no mail server to check unfortunately.
View user's profileFind all posts by rudderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
yep. It's a known problem. Gmail either ignores or moves to Junk. Tell them to stop doing this, or stop using their "service".

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 30 Aug 2006
Posts: 116
Reply with quote
Hi dmitri,

Thanks for the tip, I have changed my account profile to use my hotmail account and resubmitted a support request.

If you are interested to know, Gmail has always received Nusphere emails fine until around March 2011. Also, as I stated, the emails are not going to my Junk folder, they are not showing up at all, so they are rejected even before arriving at my mailbox.
View user's profileFind all posts by rudderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
What can I say? There is no even support behind GMAIL. No address to complain. No guys to resolve issues.
We did our best - like with google we experienced some problems sending mails to yahoo and hotmail. Looks like the problem is in the fact that most of our mails - are automated informers about new releases. These emails look very similar and sent to too many people. If you don't read the details and don't know why the emails are sent, you may think it's a spam. Fortunately, yahoo and hotmail have very elegant mechanisms to solve this problem of false spam positive and their support was very kind to help us.

With google, the snobs, it works very differently. While they have a lot of money they have no reason to work in a friendly manner (IMHO all friendly people have gone to start facebook up)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHPUnit debugging doesn't show the blue current line
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic