NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
Ian.H wrote:
I'll look into getting this feature in ASAP (hopefully this week).

That would be absolutely great! Smile

Ian.H wrote:
[EDIT 04:05]: Almost have this working Smile

I'm looking forward to it... Wink

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message


Joined: 06 Jul 2009
Posts: 72
Reply with quote
Hi all..

Release 1.2.0 (build 1201) is available from the first post. This now includes a 'Migrate' tab and will allow you to migrate settings from any version to any version. I don't think there's a need for an explanation on how to do it.. but if there are any queries, please don't hesitate to ask.

Please, export your settings before running a migration. I have tested this multiple times, with multiple scenarios.. but just to be safe Smile

Enjoy another hopefully useful release Smile



Cheers..

Ian
View user's profileFind all posts by Ian.HSend private message
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
Great, I'll download and install it now, then I can upgrade to PhpED 10 without having any reservations. Wink

Thank you very much again for your helpful tool!

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
It's four months ago that I last exported my settings. Is it normal that there's a confirmation dialog showing the path to the templates?

Apart from that the export worked fine.

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message


Joined: 06 Jul 2009
Posts: 72
Reply with quote
Hi Jan..

I fixed that in the previous build IIRC (certainly not in the latest release). It was a debugging message I'd forgotten to remove. As you say, the export will work just fine.. it just displays an (annoying) message to the templates path.

You should be good with the new version Smile



Cheers..

Ian
View user's profileFind all posts by Ian.HSend private message
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
Ian.H wrote:
You should be good with the new version Smile

Well, this happened while using the new version... Wink But no problem, the main thing is, it works.

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message


Joined: 06 Jul 2009
Posts: 72
Reply with quote
Enigma wrote:
Ian.H wrote:
You should be good with the new version Smile

Well, this happened while using the new version... Wink But no problem, the main thing is, it works.

Cheers,
Jan



Argh! You're right, of course Jan... I must have re-introduced this. I'll get it fixed tonight once at home and release a minor patch as it's not right.

Glad it all worked just fine though Smile



Cheers..

Ian
View user's profileFind all posts by Ian.HSend private message
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
Ian.H wrote:
I'll get it fixed tonight once at home and release a minor patch as it's not right.

Take your time - it's just a little "optical" glitch everyone can live with for a while, I guess. Smile

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message


Joined: 06 Jul 2009
Posts: 72
Reply with quote
1.2.1 1202 released.

This removes the debugging messagebox when exporting now.. apologies about that.



Cheers..

Ian
View user's profileFind all posts by Ian.HSend private message


Joined: 30 Jun 2009
Posts: 80
Reply with quote
Hi Ian,

It looks like there's a bug migrating HKEY_CURRENT_USER\Software\NuSphere\PhpED9.0\Toolbar\LastChk key from v9 to v10.

In v9 its type is REG_QWORD, and it gets imported into v10 as REG_DWORD. As a result, each time PHPEd tries to check the new version, there's a modal popup complaining about LastChk value/type.

Thanks,
Temuri
View user's profileFind all posts by temuriSend private message


Joined: 06 Jul 2009
Posts: 72
Reply with quote
Hi Temuri..

temuri wrote:
Hi Ian,

It looks like there's a bug migrating HKEY_CURRENT_USER\Software\NuSphere\PhpED9.0\Toolbar\LastChk key from v9 to v10.

In v9 its type is REG_QWORD, and it gets imported into v10 as REG_DWORD. As a result, each time PHPEd tries to check the new version, there's a modal popup complaining about LastChk value/type.

Thanks,
Temuri



Thanks for reporting this bug. I've fixed this now and released 1.2.2.1203.

Running the migration from 9.x to 10.x again will import the registry data types correctly (although I think this is the only one that failed, looking at the other reg types).

Apologies about this... ironically, I have a 'Toolbar' key outside of my version keys too which has my lastchk value in it (not the toolbar keys within the versioned keys), and as this doesn't get migrated as it's not part of a particular version is probably how I missed this. Anyway, the whole reg data type is now much more robust, so it shouldn't matter what they might be in the future.



Cheers..

Ian
View user's profileFind all posts by Ian.HSend private message
Great tool, thanks


Joined: 03 Nov 2012
Posts: 8
Location: United States
Reply with quote
Love it ! great work, thanks!

and in case anyone is wondering i watched for any outgoing network packets from the program and there was none, its safe and not trying to steal any of your data =)
View user's profileFind all posts by detainSend private message
PhpED Settings Mgr - Import/export your settings [Rel 1.3.0]
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 3 of 5  

  
  
 Reply to topic