NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
phped remote debugging bug (?) - timeout kills phped


Joined: 26 Jan 2014
Posts: 15
Reply with quote
Hi,
remote debugging with phped is wonderful, if there's no timeout in your work. But it can be very strange and annoying after a remote timeout (for example debugging of a session oriented application like Zend or Joomla). In this case Phped cannot be closed, projects and workspaces cannot be changed or saved even if it looks as if you can go ahead with your work. But nothing is as normal, no file can be saved, no file can be loaded. At the end you'll give up and have to kill the app - very very annoying if this happens dozens of times each day. In every case you'll lose all your favourites, all your breakpoints, files which has been opened.
Your help is highly appreciated.
Thank you very much
Otto
View user's profileFind all posts by ottovinzentSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
You will need to explain a bit more but your debugging setup and what messages/errors you maybe see.

I do *all* my debugging remotely, mostly using a Windows 8.1 desktop with PhpED latest version and a Windows 2012 Server with Apache. Most of my current work is with Magento (Zend) and I spend significant time in some debug sessions, sometimes many minutes on a single request trying various things and analysing. I'm reasonably sure that in the past I've left a debug session sitting at a breakpoint for more than an hour, gone back to it and continued just fine. I don't get timeouts from PhpED, the debugger, Apache or anything else.

I use external Firefox for debugging and that did used to timeout on the request, so I turned off the Firefox request timeout setting.

In the past I reported a bug where PhpED can sometimes show dialogs but they go behind PhpED so you cannot see them. That makes PhpED look like it is not responding, but pressing Escape was sometimes enough to cancel the dialog. What version of PhpED are you using?
View user's profileFind all posts by plugnplaySend private message


Joined: 26 Jan 2014
Posts: 15
Reply with quote
Thank you plugnplay for your reply.
I've a similar debugging environment with Windows 7, Firefox and the Firefox toolbar (I've also tried it with the debug command line option, but this doesn't play a role). Also I'm working with different server environments with their also different timeout settings. In every case I'm getting issues after the first timeout has occurred. There's no error message, not any reaction by phped, it only falls in a let's say 'sleep mode' where many of the normal reactions now are impossible or very strange. Some commands are still working and you can click at any button. Often I could even go ahead with debugging my project. Extremely strange but if I try to close my project, close phped, ALT F4 or clicking at File-close - then phped doesn't close and it seems to be unable to show any reaction (no background dialogue or anything else). In this case also debugging stops working. The only thing you can do in this case is killing the whole phped by system killing methods Sad
Here in my case this happens 5 until 100 times each day in every server environment (surely with all the different timeouts the different servers may have). It's one of the most annoying things with working with phped and I wonder why you don't get this timeout issues. Could it be a Browser issue? But I've also tried Chrome with the same results. I've checked without firewall or without virus tools, it doesn't play a role.
View user's profileFind all posts by ottovinzentSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
What version of PhpED ?

What version of DBG on each server and are they all running the same version of DBG?

Have you confirmed you are using the correct Thread Safe or Non Thread DBG for each server? Using the wrong one may appear to work, but will be unstable.

Are you using any other 'unusual' Apache extensions?

For reference, on a Windows 2012 x64 server which is running 32-bit Apache from the NuSphere TechPlatform, I use the x86 Thread Safe version of DBG from the directory C:\Program Files\NuSphere\PhpED\debugger\server\Windows\x86_VC9
View user's profileFind all posts by plugnplaySend private message
phped remote debugging bug (?) - timeout kills phped
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic