NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PhpEd no longer wants to use pre-PHP 7


Joined: 04 Apr 2017
Posts: 14
Reply with quote
Hi,

Because of odbc problems in PHP 7, I backed out to development on 5.6. I selected PHP 5.3 through 5.6 in Run & Debug/Settings, and made sure that the Path in the SRV Web Server is correct, for php 6.

But PHPEd is still pointing to 7. If I start the code with a phpinfo(), it says it's PHP Version 7.1.6.


I've tried both SRV Web Server and Local Server. In IIS, it's configured for 5.6 now.


How do I get PHPEd to recognize and use another version, other than php 7?
View user's profileFind all posts by NSUserSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7868
Reply with quote
check Tools -> Settings > SRV web server and Tools -> Settings -> PHP CLI for srv and cli run mode respectively.
You need to make sure that php5.3-5.6 line points to php-cgi.exe and php.exe of version 5.6 respectively.
Then make sure this line is in effect by selecting php5.3-5.6 on project properties -> Parser properties page. If project-specific parser properties are not enabled, you have to select them in global settings: on tools->settings->Code Insight -> Settings page (see target php version input)
Also you may want to make sure that you are running SRV or CLI because otherwise php version is not under PhpED's control.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Apr 2017
Posts: 14
Reply with quote
"Then make sure this line is in effect by selecting php5.3-5.6 on project properties -> Parser properties page."

This is the reason, thanks dmitri.




dmitri wrote:
check Tools -> Settings > SRV web server and Tools -> Settings -> PHP CLI for srv and cli run mode respectively.
You need to make sure that php5.3-5.6 line points to php-cgi.exe and php.exe of version 5.6 respectively.
Then make sure this line is in effect by selecting php5.3-5.6 on project properties -> Parser properties page. If project-specific parser properties are not enabled, you have to select them in global settings: on tools->settings->Code Insight -> Settings page (see target php version input)
Also you may want to make sure that you are running SRV or CLI because otherwise php version is not under PhpED's control.
View user's profileFind all posts by NSUserSend private message
PhpEd no longer wants to use pre-PHP 7
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic