NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHPEd extreme memory/CPU usage & Code Navigator is empty


Joined: 18 Feb 2013
Posts: 16
Reply with quote
Hello! Starting yesterday, two things happened at the same time:

1. The Code Navigator window stopped working; while set to show all class methods, data, etc, suddenly it was empty; there was no change in the navigator settings.
2. PHPEd was showing extremely high CPU and memory usage in the Windows task manager (about 1.3Gb of memory). This happened even with a very small project that only has about 7 files, none of them large

I tried all of the following without success: Restarting the IDE, restarting the computer, closing and re-opening the class modules within the IDE, and right-clicking the file name in the Code Navigator and clicking Refresh.

Finally I did a Windows system restore, un-doing a recent Windows update. That did fix both problems, but only temporarily. A short while later, while working in the IDE, both issues suddenly and inexplicably came back. So clearly it had nothing to do with the Windows update, since the same thing is now happening with the pre-updated version of Windows.

Running version 19.1, build 19116, 16 bit.

Thank you for your help! PhpEd is essential to my work process, so I'm anxious to get this resolved.

Best regards,
Gordon Kramer
View user's profileFind all posts by gskramerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
I'd check antivirus in the first place. What AV do you run btw?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Feb 2013
Posts: 16
Reply with quote
Yes, that was about the first thing I did (using Webroot), because the behavior was so strange; also ran anti-spyware, memory tests, registry cleanup, and a few other things. I finally did solve it. Chrome is my default browser for debugging, and there appeared to be some kind of interaction between PHPEd and a Chrome add-in I was using to test REST requests, called YARC. As soon as I switched from YARC to another REST client (Boomerang), the PHPEd issue went away. But I can't explain why that fixed it!
View user's profileFind all posts by gskramerSend private message
PHPEd extreme memory/CPU usage & Code Navigator is empty
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic