NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Php documentor *solved*


Joined: 06 Mar 2006
Posts: 5
Reply with quote
Hello there.

I have been reading some threads on this forum and I used the information to change the Php Documentor command as suggested. Thus the documentor starts OK, bu it fails on the followings errors (below).

The main problem appear that the documentor expects Smarty version 2.6.0, but the version installed with the PhPedit in the Php documentor folder is 2.5.0. Simply renaming the directory did not help. What is the simplest solution, withou reinstalling the PhpEdit, if possible.

Thank you in advance for your ideas/suggestions.

Scisoft


"Script", "C:\Program Files\nusphere\phped\php\php.exe "C:\Program Files\nusphere\phped\phpDocumentor\phpDocumentor\phpdoc.inc" -t "c:\web\docs " -d "C:\web\your prague\web"", "21:40:28", ""
"Script", "X-Powered-By: PHP/4.4.1", "21:40:28", ""
"Script", "Content-type: text/html", "21:40:28", ""
"Script", "", "21:40:28", ""
"Script", "<br />", "21:40:28", ""
"Script", "<b>Warning</b>: main(phpDocumentor/Smarty-2.6.0/libs/Smarty.class.php): failed to open stream: No such file or directory in <b>C:\Program Files\nusphere\phped\phpDocumentor\phpDocumentor\Converter.inc</b> on line <b>30</b><br />", "21:40:28", ""
"Script", "<br />", "21:40:28", ""
"Script", "<b>Warning</b>: main(): Failed opening 'phpDocumentor/Smarty-2.6.0/libs/Smarty.class.php' for inclusion (include_path='C:/Program Files/nusphere/phped/phpDocumentor;.;C:\Program Files\nusphere\phped\php\..\include_lib;C:\Program Files\nusphere\phped\php\PEAR') in <b>C:\Program Files\nusphere\phped\phpDocumentor\phpDocumentor\Converter.inc</b> on line <b>30</b><br />", "21:40:28", ""
"Script", "PHP Version 4.4.1", "21:40:28", ""

.....

"Script", "<b>Fatal error</b>: Cannot instantiate non-existent class: smarty in <b>C:\Program Files\nusphere\phped\phpDocumentor\phpDocumentor\Converter.inc</b> on line <b>4824</b><br />", "21:40:28", ""
"Script", "", "21:40:28", ""
"Action", "Failed to navigate to URL: C:\web\docs \index.html", "21:40:28", "" Crying or Very sad
View user's profileFind all posts by scisoftSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
yes indeed, both Converter.inc and pear-Converter.inc expect smarty to be in 2.6.0 directory:
include_once("phpDocumentor/Smarty-2.6.0/libs/Smarty.class.php");
and smarty itself is 2.6.0 (see Smarty.class.php, var $_version = '2.6.0'Wink
so renaming the directory should help.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 06 Mar 2006
Posts: 5
Reply with quote
Thank you for the answer. Renaming the directory did not work for me, but I may have messed something else. In any case, dowloading the phpdocumentor package and replacing the installed one worked at the end.
View user's profileFind all posts by scisoftSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
it's fixed in phped v4.5 build 4510
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Php documentor *solved*
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic