NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHP 5.4.6 Zend 220090626. Get later version of DBG


Joined: 08 Oct 2012
Posts: 3
Reply with quote
FreeBSD 8.2
PHP 5.4.6
dbg-4.6.3

Extensions API 220100525
Modules API 20100525
PHP API 20100412

[httpd-error.log]
DBG requires Zend Engine API version 220090626.
The Zend Engine API version 220100525 which is installed, is newer.
Contact Dmitri Dmitrienko at www.nusphere.com for a later version of DBG.



Is there a newer/different version of dbg which will run with PHP 5.4.6 & Zend 220090626?

Thanks
View user's profileFind all posts by ghost9Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7895
Reply with quote
The message is totally misleading and generated by PHP itself.
If you recently upgraded php to version 5.4, you also have to update dbg module - replace module with the one supporting php 5.4. Version of dbg itself remains the same - 4.6.3.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Oct 2012
Posts: 3
Reply with quote
I have PHP 5.4.6 and dbg-4.6.3 for php 5.4. All works, but the message still displays.
There is a way to remove the message from log?
View user's profileFind all posts by ghost9Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7895
Reply with quote
what you're trying to load is dbg-4.3.6 for php 5.3, not 5.4 -- this causes the problem.
Check you php.ini and all files loaded as part of php.d (check your phpinfo, then all files listed in php.d)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Oct 2012
Posts: 3
Reply with quote
I copy file from C:\Program Files\NuSphere\PhpED\debugger\server\dbg-4.6.3-FreeBSD\x86_64\dbg-php-5.4.so
Version for php 5.4. And I have installed PHP 5.4.6.


PHP Version 5.4.6
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
with DBG v4.6.3, (C) 2000,2012, by Dmitri Dmitrienko

DBG php debugger, version 4.6.3
Version 4.6.3
Linked as a shared library.
Dbg SSL not available
Dbg ip security enabled.
Profiler enabled
Target PHP version 5.4.x
Server API Apache 2.0 Filter
Extensions API 220100525
Modules API 20100525
PHP API 20100412

All works, but message is still displayed.
View user's profileFind all posts by ghost9Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7895
Reply with quote
You don't hear me. I repeat -- check all the files for _ANOTHER_ dbg module which you're _ALSO_ trying to load Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHP 5.4.6 Zend 220090626. Get later version of DBG
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic