NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Nusphere asking for handler, after updating


Joined: 04 Apr 2017
Posts: 28
Reply with quote
Hi,

After updating to the latest build in Nusphere 19 Pro, and selecting NOT to overwrite the .ini files, and after <Ctrl><F9>,


index.php file is recognized as php 7.x, but php cgi has no handlers configured to run it. You may want to add handler for PHP 7.x on the next form.


I don't understand what it's asking for. The projects didn't receive this message yesterday, before the update.


Regards,
View user's profileFind all posts by NSUserSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7942
Reply with quote
Try Tools->Settings->SRV web server, click [Reset] button, then open Tools->Setings->PHP CLI and also click [Reset] button.
This will set CLI and CGI handlers for cli and SRV web server variants of running your scripts.

Regarding php.ini, you may still need to update them to have the latest debugger included. Check phpinfo() output. If it shows dbg-9.1.5 -- the version that comes with current version of PhpED, then you're all set, otherwise please run Project Settings Wizard and it will explain you what to fix and how.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Apr 2017
Posts: 28
Reply with quote
All set, thanks dmitri.

Woop. I take it back. The application runs normally, but can't run the debugger. <Ctrl F9> is available, but not F9.

Ok, I need to reconfigure debugging. Maybe I should just reinstall, but this time overwrite the .ini files.

phpinfo() does return 9.1.5, but maybe it's still necessary to take all the defaults when installing.




dmitri wrote:
Try Tools->Settings->SRV web server, click [Reset] button, then open Tools->Setings->PHP CLI and also click [Reset] button.
This will set CLI and CGI handlers for cli and SRV web server variants of running your scripts.

Regarding php.ini, you may still need to update them to have the latest debugger included. Check phpinfo() output. If it shows dbg-9.1.5 -- the version that comes with current version of PhpED, then you're all set, otherwise please run Project Settings Wizard and it will explain you what to fix and how.
View user's profileFind all posts by NSUserSend private message


Joined: 04 Apr 2017
Posts: 28
Reply with quote
Ok, everything's working, after reinstalling.

We're good.

Really. This time, it's all set.

Really.


Regards,



NSUser wrote:
All set, thanks dmitri.

Woop. I take it back. The application runs normally, but can't run the debugger. <Ctrl F9> is available, but not F9.

Ok, I need to reconfigure debugging. Maybe I should just reinstall, but this time overwrite the .ini files.

phpinfo() does return 9.1.5, but maybe it's still necessary to take all the defaults when installing.




dmitri wrote:
Try Tools->Settings->SRV web server, click [Reset] button, then open Tools->Setings->PHP CLI and also click [Reset] button.
This will set CLI and CGI handlers for cli and SRV web server variants of running your scripts.

Regarding php.ini, you may still need to update them to have the latest debugger included. Check phpinfo() output. If it shows dbg-9.1.5 -- the version that comes with current version of PhpED, then you're all set, otherwise please run Project Settings Wizard and it will explain you what to fix and how.
View user's profileFind all posts by NSUserSend private message
Nusphere asking for handler, after updating
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic