NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Mapping paths - local dev server - xampp simple setup


Joined: 13 Oct 2022
Posts: 5
Reply with quote
I have an xampp setup on Win 11. I'm experiencing an unexpected problem. I'm working on some PHP and debugging in PHPEd, but when the script ends and the "output" window / embedded chrome browser opens, it does not go to the correct URL. Watching the log, I see the debugger is following the correct URL, which would be http://localhost/my_project_folder/ , but the embedded PHPEd browser is going to http://localhost/

Have a look at this screenshot. Thats a right-click => Properties, on the project folder in the Workspace:



I don't understand what I've configured incorrectly to get that result of the wrong URL in the preview, as shown here:

View user's profileFind all posts by ajaxStardustSend private message
Re: Mapping paths - local dev server - xampp simple setup
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
ajaxStardust wrote:
but the embedded PHPEd browser is going to http://localhost/


Embedded browser is going to where you've configured it to. Then your server might re-direct it somewhere else.
You can run Settings Wizard at the bottom and re-configure it again, according to your needs. There is an option on the very first Wizard page to pick either embedded web server or an external one like XAMPP

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 13 Oct 2022
Posts: 5
Reply with quote
Your reply is useless. That's disappointing. I was going to buy the license. It started off as a good experience.

Why have a forum, if you can't be bothered to provide proper advisory?

I've read the instructions. How is my configuration not pointing the embedded browser to my desired URL?
View user's profileFind all posts by ajaxStardustSend private message


Joined: 30 May 2006
Posts: 86
Reply with quote
Sorry for interfering, but ...

@ajaxStardust
You are asking for advice. When you get it, you provide rude & offending response. Not nice.
Issues here should be pragmatically solved, rather than emotionally described so that they could be useful for other users.

@Dmitri
I believe most of issues here could be answered/resolved by other staff so you could save your precious knowledge & development time (and probably frustration sometime ..?).
View user's profileFind all posts by lubosdzSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
ajaxStardust wrote:
Your reply is useless. That's disappointing

Sorry to hear that. Sorry that my reply was treated this way.
I think you may still want to re-visit my suggestion. We invested quite a lot of efforts in the Wizard to save our customer's time. For instance, in your particular example, it's almost impossible to say why and what, if anything, went wrong. I'd have to ask for more screenshots and more test. In average such issues may require more than 2 interactions. Each takes time.
Many years ago we decided to create the Wizard that helps set the project up. The wizard streamlines the process and performs up to a hundred checks. In many cases it posts relevant suggestions on its own, so customer could figure out what should be fixed and proceed without any interactions with support. Finally, if issue couldn't be resolved, Wizard pages provide enough info for the support to root-cause the issue and provide real help with significantly less efforts and much faster.
It's not what you expected, I'm sorry. We have what we have.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Mapping paths - local dev server - xampp simple setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic