NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
loosing shortcuts
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
Does anyone else saw also this issue?:

Sometimes shortcuts back to the default scheme. I set my custom scheme but some time later (few days?) it backs to default. What is wrong ?

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
BTW. In settings -> Editor -> Editor shortcuts a Key mapping is all time set as Custom (strange?).

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
are you working with trial version?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
No, not Trial dmitri. Its newest version, but probs with shortucts started since 5.0.

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
We got some reports from people running Vista. They claimed that PhpED loses some of its settings. After a short investigation it appeared that Vista prompted to kill application while it was shutting down and they agreed. Is there a chance that something similar happened in your case?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
Sometimes when I close Application its crashes - so thats true. But im running PhpED on Wndows XP.

Before 5.0 sometimes PhpEd had been loosing other settings and now I see only shortcuts (accounts are ok, maby other too but not more settings ive changed after loosing its ALL via upgrading 4.x -> 5.x).

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
I'm not sure what you mean under "it's crashing". In case of true crash, it would prompt you to submit dumped data to nusphere site when you start the IDE next time. As I understand it did not happen and therefore it's not a crash.
If IDE stores a big ppx file and hangs for 2-5 seconds, it is definitely not a crash. With huge projects you may get ppx of 20-30MB and even more, in this case it may take 20-30seconds and more to save this file. Hope it makes sense to wait, not to kill an application while it's saving its data (for you).

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
OK, I understand. But sometimes yes, I have prompt in next starting PhpED, but I dont send it, becouse this situation is only in one case - when I try close PhpED with opened some files and any project. If I close a project and workspace and close application, there are no probs - and its true - may I do it too fast, becouse project some projects are big.

But this is not a moment I loose shortcuts.

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
then we need to know what preceeded the problem Smile

and please submit all the reports IDE asks for.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
I dont know what is the problem. Eg. Today i set my shortcuts as I want. Some time later I open PhpED and shortcuts are the same as default scheme (but shown as Custom). No errors, crashes, nothing else what could be strange.

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Can you replicate the problem consistenly?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Mar 2007
Posts: 148
Location: Poland
Reply with quote
I cant replicate it, becouse this is happening like command added to cron eg in this way: "once per few days shortcuts must be restored from default". Nothing happening with it, just closing and opening PhpED (and nothing special is happening with that).

_________________
ML
View user's profileFind all posts by introSend private messageVisit poster's website
loosing shortcuts
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic