NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Is there actually a debugger?
Veteran

Joined: 15 Nov 2003
Posts: 118
Reply with quote
Hi,

Downloaded phped latest version this morning and have been trying to get the debugger working... but cant... all i get is popups with timeout in them.

I have apache, mysql and php installed locally, and they all work file, apache diverts requests for http://localhost/ to w:\web\ where the files are served.

In w:\web\test.php i have:

<?php
phpinfo();
?>

and thats it, all i want is to see some output.... hit "test in browser" in dreamweaver and up it pops, hit debug in phped and nothing but timeout popup... what gives?

Can somone PLEASE explain how to get this working?

joe
#
View user's profileFind all posts by joebSend private message


Joined: 14 Nov 2003
Posts: 3
Reply with quote
Most likely you don't have php_dbg.dll module installed with PHP. Read phpED manual for that, installation procedure explained there.
View user's profileFind all posts by Frozen FireSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
aha, interestingly that the popup tells about the same Smile
Nobody read docs nor popups... Confused
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 15 Nov 2003
Posts: 118
Reply with quote
ok, so i didnt read the popup! Does anyone ever read popups?!

Ah well, onto the next problem...

I've got as far as copying the php_dbg.dll file from phped to my php extentions folder (c:\php\extentions\) but have read the doc Wink and its seens that the dll is for php4.3.3, im using PHP4.3.4

Can someone tell me where to get a dll for php4.3.4 ?

Joe
#
View user's profileFind all posts by joebSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
sure. Take one for php-4.3.3. It's known to be compatible and works fine.
Actually TechPlatform 3.1 contains php_dbg.dll-4.3.4 the same as php_dbg.dll-4.3.3.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 15 Nov 2003
Posts: 118
Reply with quote
ok, i have now copied the dll to the c:\php\ dir (my php instalation dir) and added this to php.ini:

extension=php_dbg_433.dll

[Debugger]
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow=localhost, 127.0.0.1,localhost:9000
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16

I've created a project and all the files in the website are visable in the file browser, i have edited the project settings, set:

root dir: w:\web\
run mode: HTTP remote WEB server
root URL: http://localhost/
remote root dir: w:\web\

open a file, hit run, i get the expected output.

open a file, hit debug, i get this error in the output window:

DBG
Failed to start debug session
reason:
failed to establish connection to the client address 127.0.0.1:7869


What am i missing?

joe
#
View user's profileFind all posts by joebSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
It means that either DbgListener was not run or DbgListener was run on a different port or you have a firewall installed that protects your localhost from itself.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 15 Nov 2003
Posts: 118
Reply with quote
yep it was the filewall.

It's all working sweetly now, many thanks to all that helped..


Joe
#
View user's profileFind all posts by joebSend private message
Is there actually a debugger?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic