NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Installed PHP versions


Joined: 22 Feb 2017
Posts: 6
Reply with quote
Are the 3 installed PHP versions 5.2, 5.7 and 7.0 required? Only one I'm interested in 7.0
View user's profileFind all posts by riderForumSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7828
Reply with quote
they are required only if you use php-5.0-5.2 or php-5.3-5.6. If you're using only php-7.0, you can safely uninstall them by running unins000.exe in their directories

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
php 5.2 and 5.6


Joined: 22 Feb 2017
Posts: 6
Reply with quote
I assumed that was the case; but, didn't want to screw up the whole phpEd installation.
View user's profileFind all posts by riderForumSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7828
Reply with quote
you can select target php version on project properties -> parser properties page. The drop down has 4 chooses: 4.x, 5.0-5.2, 5.3-5.6 and 7.x. These versions select what php parser will check your sources and what code completion for standard functions/classes will appear. This is a built-in functionality that does not depend on php installed on your system.
In case if your project Run Target is "Srv Local", IDE runs php.exe or php-cgo.exe configured on Tools->Settings-> PHP CLI or SRV web server pages respectively. This is the only place where those 3 versions of PHP appear and used.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Installed PHP versions
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic