NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Howto: Upgrade CSE HTML Validator


Joined: 12 Feb 2012
Posts: 5
Reply with quote
PhpED comes pre-configured with CSE HTML Validator Lite version.

If you purchase a different version of CSE HTML Validator, and wish to use it from within PhpED instead of the Lite version, I have found this worked for me:

1. Install the version of CSE HTML Validator you purchased.
2. Locate the .dll file for HTML Validator. I bought version 11.0, so on Win 7 (64bit) the .dll file is in the program folder: C:\Program Files (x86)\HTMLValidator110 and the file name is: csevalidatorV110.dll
3. In PhpED, select Tools - Settings from the menu.
4. In the Settings dialogue, scroll down to Tools - Extrnal Tools.
5. On the line: CSE Validator use the "folder' icon to navigate to the .dll file located above, and select it
6. OK you Settings dialog, and you are finished.

Regards, Jeremy
View user's profileFind all posts by Jeremy StannersSend private message


Joined: 07 Mar 2012
Posts: 14
Reply with quote
If installed w/o CSE Validator Lite 6.5 (from 2004) PhpED picks up an installed current version of CSE automagically, with the above ceremony not required. However, also consider this comment from this thread:

dmitri wrote:
In fact no newer versions of CSE Lite would work stable under PhpED -- they crash almost immediately after some calls because CSE is trying to show nag window and does so in the thread the library is called in. Because we use a dedicated worker thread for all kinds of background processes, CSE calls GUI functions from this thread. CSE is written in a library that it's not intended to call GUI from threads other than main thread and such calls results in crashes in CSE itself.
Some years ago I already contacted Albert, but seems he didn't find a proper solution for us.
BTW you can try your best and pass your questions to him too.


JayAitch

_________________
JH
View user's profileFind all posts by jayaitchSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7904
Reply with quote
hmm, if you purchase CSE, it will be CSE commercial version, not CSE Lite.
Commercial version does not try to show nag windows and it works stable.
I know some of our customers are using v10 and v11 version of CSE Validator quite successfully.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 Mar 2012
Posts: 14
Reply with quote
My fault, missed the Lite. Matter of fact, except for the
Code:
Check for characters 128-159 (does not apply to Unicode encoded documents)
option related thing from our other thread v.11 Std. works fine here, too.

I had used CSE Lite 10 for some time, however, I am not certain if it was used by PhpED 6.2, too. With some other applications, incl. TopStyle 4/5, there were no nags though.

JayAitch
View user's profileFind all posts by jayaitchSend private message
Howto: Upgrade CSE HTML Validator
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic