NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
How to use PHP 5.4?


Joined: 29 Sep 2004
Posts: 62
Location: �' AND sleep(21); /*
Reply with quote
I'm running phped 9055 and thought it was using php 5.4, but when I run phpinfo I see it's actually running php 5.3.9. How do I make it run php 5.4?
View user's profileFind all posts by pointySend private messageVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
How to use PHP 5.4? [RESOLVED]


Joined: 29 Sep 2004
Posts: 62
Location: �' AND sleep(21); /*
Reply with quote
Okay, blank moment there, obviously I was checking the version of my own PHP installation. About 2 seconds after posting to the forum it struck me I'd set phped to use a 3rd party web server, after switching the phped run mode to the built-in web server I saw it uses php 5.4

The latest Tech Platform 8.1 (which I use) uses php 5.3 so if you're using this or some other package you might have to upgrade manually.
I couldn't find any instructions for upgrading to php 5.4 so I thought it might be useful for others if I put something here.

So to upgrade to php 5.4 for windows:
- download the php zip from php.net at windows.php.net/download/
- exit phped if it's running
- in services stop the apache service
- rename your existing php folder to something like php53
- create a new empty php folder and unpack the php zip into it
- copy one of the default php.ini files to php.ini (I used php.ini-development)
- merge your original php53\php.ini with the new php.ini (you can probably just copy your original php.ini but I saw there were some changes for php 5.4)
- restart the apache service
- run phped and open a project
- under Project Properties run the Settings Wizard to sort out the debugger - when asked "Do you want Dbg-Wizard to fix the problem" click Yes and follow instructions
- while in project settings fix the annoying localhost ipv6 problem (is it only me?) - click Debugger settings, tick "Use SSH tunnel" and set the Tunnel listening address to 127.0.0.1
- save the settings and try debug your project, you should now be using php 5.4
- if it all works you can delete the backup folder php53, or leave it if you want to be able to switch between 5.3 and 5.4
View user's profileFind all posts by pointySend private messageVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
Site Admin

Joined: 13 Jul 2003
Posts: 8184
Reply with quote
in fact v9 comes with php 5.4, not with php 5.3. Latter is available separately. If you've already installed 5.3, you can switch back to 5.4 -- just update path to php executables on SRV and CLI settings. What you need to change is "php 5.3 and higher" line.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
How to use PHP 5.4?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic