NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] how to install debugger


Joined: 05 Apr 2008
Posts: 17
Reply with quote
It seems to put error in my php.ini but as far as i can tell, php.ini looks okay:

Code:



extension=/usr/lib/php/modules/dbg.so-5.1.x

[debugger]
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow=192.168.2.57 localhost
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16

; zend_extension = /usr/lib/php/modules/ioncube_loader_lin_5.1.so



The ion cube is commented out as you can see and there isn't any other zend_extension.

Now HTTPD won't start. It started for me once and dbg-wizard still told me it wasn't installed and gave me similar [debugger] line settings.

I'm using the evaluation version. Build 5233eval

weather it works with evaluation version or not, the server should work by itself.


SO file exists HERE:

/usr/lib/php/modules/dbg.so-5.1.x

already checked that.

I restart apache with
service httpd stop
...................start.

I have Fedore Core 6 i believe.

Thanks,


DM
View user's profileFind all posts by dlite922Send private message
Re: Another Remote Debugger Problem


Joined: 05 Apr 2008
Posts: 17
Reply with quote
apache starts now, but dbg-wizard.php still says it is not installed.

Code:
PHP Version: 5.1.6
Web Server: Apache/2.2.0 (Fedora)
Server Name: 72.16.128.44
OS: Linux
Your Client IP Address: 192.168.2.1
Your Server IP Address: 192.168.2.254
Port: 80
Your Web Server and PhpED are on different machines
Path to website files: /var/www/html/nexus/
Document Root is: /var/www/html/
Your PHP.INI file is /etc/php.ini
PHP extensions directory is /usr/lib/php/modules
DBG (PHP DEBUGGER) is NOT INSTALLED
View user's profileFind all posts by dlite922Send private message
Guru master

Joined: 05 Jul 2004
Posts: 659
Location: Belgium
Reply with quote
I'm not sure what happens if you specify both the hosts_allow and the hosts_deny lineā€¦ perhaps the deny takes precedence and won't allow any connections.
IMO only the allow line suffices so perhaps it will work if you comment out the line with hosts_deny. It's worth a try I guess
View user's profileFind all posts by BlizzSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
extension=/usr/lib/php/modules/dbg.so-5.1.x

this is the problem.
You can not use full path in the "extension=blahblahblah" statements. Just plain module file name and this module must be in the directory pointed by extension_dir setting:
extension=dbg.so-5.1.x


Alternatively you can use zend_extension (zend_extension_ts in case if Thread Safety is on) and it's where you have to specify full path:
zend_extension=/usr/lib/php/modules/dbg.so-5.1.x

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 05 Apr 2008
Posts: 17
Reply with quote
dmitri wrote:
Quote:
extension=/usr/lib/php/modules/dbg.so-5.1.x

this is the problem.
You can not use full path in the "extension=blahblahblah" statements. Just plain module file name and this module must be in the directory pointed by extension_dir setting:
extension=dbg.so-5.1.x


Alternatively you can use zend_extension (zend_extension_ts in case if Thread Safety is on) and it's where you have to specify full path:
zend_extension=/usr/lib/php/modules/dbg.so-5.1.x


thanks i'll try that. Very Happy
View user's profileFind all posts by dlite922Send private message
[resolved] how to install debugger
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic