NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Help: Enabling TLS in cURL?


Joined: 20 Jun 2014
Posts: 3
Reply with quote
Hi,

I'm writing code to use the Google Analytics API. The Analytics API library uses cURL to access Google's servers. When I run my PHP code on a web server (my Linux-based Network Attached Storage server), it works. But if I run it in the PhpED debugger, cURL throws an error #60 (CURLE_SSL_CACERT, Peer certificate cannot be authenticated with known CA certificates.)

Is this a problem with my PC lacking a certificate? (I have Windows 7 x64, fully up to date). Or is it a problem with cURL being unable to locate my PC's certificate or not having TLS enabled? Either way, how do I fix the problem?

Thank you,
Bob
View user's profileFind all posts by altairSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7835
Reply with quote
I think PhpED is not somehow involved. Just check -- will you get the same problem if you run this code on the Windows machine directly, meaning without PhpED?
If it also produces the same error, you need to investigate cURL and your machine. Most likely you need to refresh CA bundle from Mozilla site. Try to google for "mk-ca-bundle.pl" and for "cURL CA bundle"

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Help: Enabling TLS in cURL?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic