NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
FTP connection Error


Joined: 14 Dec 2011
Posts: 6
Reply with quote
Some time ago the connection fails PhpED to an FTP server. I tried by all means to set something that older versions of PhpED did not happen Sad .

I do exactly the same settings in:
- PhpED 9.0 build 9055 (image1)
- phpDesigner 7 and 8 (image2)
- CuteFTP 8.0 Pro (image3)


Image 1 (PhpED 9.0 build 9055)


Image 2 (phpDesigner)


Image 3 (CuteFTP 8.0 Pro)

Only with PhpED the connection fails. In phpDesigner and CuteFTP there is no problem.

PhpED is thinking and shows the following error "Failed to list files in '/' folder. Timeout read". (image 4).


Image 4 (Error Phped)

Greatly appreciate the help of how to solve this problem.

Thanks
View user's profileFind all posts by ertysSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
I think it's something with your local firewall.
Try for example ftp.mozilla.org
it's known to work fine. If it does not open, check your local windows setup.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Apr 2014
Posts: 5
Reply with quote
Quote:
I think it's something with your local firewall.


Did you get the part that he used 3 clients, only phpEd failed?

A firewall does not differentiate between clients, only Protocols/IP addresses & ports

I am having the same issue on version: 12.0 (Build 12047, 64bit)
I can connect successfully with CuteFTP & FileZilla
When I use PhpEd, it fails with that same read timeout error as above.

My settings are exactly the same as ertys

I think there is something wrong with the the FTP functionality within phpEd.

The other problem is that there does not seem to be a log where I can find what is happening on the FTP side.

Here is a log from FileZilla:

Code:
Status:   Connecting to ***.***.***.***:21...
Status:   Connection established, waiting for welcome message...
Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:   220-You are user number 2 of 5 allowed.
Response:   220-Local time is now 10:49. Server port: 21.
Response:   220-This is a private system - No anonymous login
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:   USER *****
Response:   331 User ***** OK. Password required
Command:   PASS **********
Response:   230 OK. Current directory is /
Command:   SYST
Response:   215 UNIX Type: L8
Command:   FEAT
Response:   211-Extensions supported:
Response:    EPRT
Response:    IDLE
Response:    MDTM
Response:    SIZE
Response:    MFMT
Response:    REST STREAM
Response:    MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:    MLSD
Response:    AUTH TLS
Response:    PBSZ
Response:    PROT
Response:    UTF8
Response:    TVFS
Response:    ESTA
Response:    PASV
Response:    EPSV
Response:    SPSV
Response:    ESTP
Response:   211 End.
Command:   OPTS UTF8 ON
Response:   200 OK, UTF-8 enabled
Status:   Connected
Status:   Retrieving directory listing...
Command:   PWD
Response:   257 "/" is your current location
Command:   TYPE I
Response:   200 TYPE is now 8-bit binary
Command:   PASV
Response:   227 Entering Passive Mode (172,31,26,182,195,85)
Status:   Server sent passive reply with unroutable address. Using server address instead.
Command:   MLSD
Response:   150 Accepted data connection
Response:   226-Options: -a -l
Response:   226 3 matches total
Status:   Directory listing successful
View user's profileFind all posts by TalonZaSend private message
Guru master

Joined: 24 Jul 2009
Posts: 717
Reply with quote
Absolutely a local firewall can differentiate between clients. There many application aware firewalls.

The built-in Windows Firewall is application aware. Go have a look at the rules in Windows Firewall with Advanced Security and you will see it has applications (Program column) listed in there with the protocols they are allowed to utilise.

PhpED does add a rule to Windows Firewall to allow phped.exe access to all protocols, but I guess sometimes something else might interfere with adding that rule, or another rule could conflict and block access, or the computer is using a different firewall.

I use PhpED on 3 different computers (Windows 8.1, Windows 7.0 and Windows Server 2003) together with around 50 FTP accounts defined (I copy them between the computers) and never have a problem, *except* there was an older version of PhpED that did have FTP problems. Might have even been the first few releases of PhpED 9.0

I'm certainly not saying you haven't found a problem with PhpED, and there are issues that some people have and for some reason others do not, but it can be your firewall and it is worth checking that. Wink

A full PhpED FTP log file is something that I would also like to see available.
View user's profileFind all posts by plugnplaySend private message


Joined: 09 May 2014
Posts: 1
Reply with quote
I had some ftp problems myself.

Uploading was very slow, disconnects, no connects at all.
Nusphere was on my system, and the ftp/webserver on a local virtual machine.

i disabled all firewalls and still the same problems.
as it turned out, the problems were related to the ftp server used

i tried BabyFTP and Quick'n'Easy Ftp Server as there where portable editions available and i did not want to install anything.
none of these worked correct with phpED. The servers were always complaining about to many users logged in at the same time allthough i enabled more than 500 user-connections

After i used Filezilla FTP Server the problems were gone

I saw that phpED opened many connections to the ftp server(but i did not find a switch to configure how many connections are used) and maybe some ftp servers cannot handle this?

btw: i'm using phpED 13
View user's profileFind all posts by funkyjaySend private message
FTP connection Error
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic