NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
force-cgi-redirect problem


Joined: 02 Oct 2003
Posts: 3
Reply with quote
I just upgraded to php 4.3.3. Now, when I try to run a script in PHPEd, I get the following error:

Security Alert! The PHP CGI cannot be accessed directly.
This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.

For more information as to why this behaviour exists, see the manual page for CGI security.

For more information about changing this behaviour or re-enabling this webserver, consult the installation file that came with this distribution, or visit the manual page.


Is there any way to work around this issue.

TIA,

Brad
View user's profileFind all posts by BradHSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
I believe phped has nothing to do with Apache<->php relation.
Please read php manual or search through the internet.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 02 Oct 2003
Posts: 3
Reply with quote
I don't think the message only used Apache as an example. I think what I need to do is to find a way to set a similar variable in the config for the PHPEd web server. Can that be done?
View user's profileFind all posts by BradHSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Can you please tell me what you mean under PHPED WEB server ? Confused
PHPED has one named SRV but there is no such problem with it abd I see no reason for updating to 4.3.3 because PHPED 3.2.1 is shipped with 4.3.3.

Could you please specify in more details what do you run ?

TIA
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 02 Oct 2003
Posts: 3
Reply with quote
I'm running 2.99.1.
View user's profileFind all posts by BradHSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Sorry, 2.99 is a free and not-supported version.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
force-cgi-redirect problem
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic