NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Error checking php installation using wizard


Joined: 27 Nov 2009
Posts: 98
Reply with quote
I have PHPed 19.5 Build 19521 64 bit running on Windows and PHP 8.1.2 running on Ubuntu 22.04 LTS, and get the following error. Is this only caused because I need to upgrade PhpED due to the PHP 8.1.2 version? Will IOHandler value is not valid and It's possible that your server platform Linux-glibc-2.35/x86_64 is not supported no longer be an issue? Thank you

Code:
 .php file extension is associated with PHP
 Error: (-105) failed to download dbg-wizard (IOHandler value is not valid)
 uploaded dbg-wizard.php to [SFTP:ubuntu] /var/www/abtfile/public/
 Warning: (-30) Failed to verify /O=Digital Signature Trust Co./CN=DST Root CA X3 SSL certificate, embedded browsers may fail to work
[E=10: certificate has expired]
 Warning: (-30) Failed to verify /C=US/O=Internet Security Research Group/CN=ISRG Root X1 SSL certificate, embedded browsers may fail to work
[E=10: certificate has expired]
 Warning: (-30) Failed to verify /C=US/O=Let's Encrypt/CN=R3 SSL certificate, embedded browsers may fail to work
[E=10: certificate has expired]
 dbg-wizard version is 4.2.4203
 client outbound IP=12.345.6.78, another network
 Warning: (-23) platform is Linux-glibc-2.35/x86_64, it's probably not supported (Php version 8.1.2 is not supported by this product. Please check for the product updates at https://shop.nusphere.com/), please consult with list of supported platforms on this page
 php version 8.1.2, ts: 0, sapi: fpm-fcgi
 php.ini file is /etc/php/8.1/fpm/php.ini
 php extension_dir /usr/lib/php/20210902
 document root /var/www/abtfile/public
 Error: (-120) debugger module is not installed
 please re-run this wizard and make sure that everything is entered correctly; if nothing helps, please make screenshots of all of the wizard pages and contact NuSphere support https://shop.nusphere.com/contact_us/
 It's possible that your server platform Linux-glibc-2.35/x86_64 is not supported
Php version 8.1.2 is not supported by this product. Please check for the product updates at https://shop.nusphere.com/


or open this FAQ page:
http://www.nusphere.com/kb/technicalfaq/howto_install_dbg_module.htm
and proceed with instructions
 You may want to either install a valid SSL certificate onto your web server or switch to an external browser
 please make screenshots of all of the wizard pages and contact NuSphere support https://shop.nusphere.com/contact_us/
 fix the problem(s), then click [<< Back] button and repeat the tests
View user's profileFind all posts by NotionCommotionSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8256
Reply with quote
As far as I can tell:
1) `[E=10: certificate has expired]` -- is an indication that either of the certificates in the chain has been expired.
2) `Warning: (-23) platform is Linux-glibc-2.35/x86_64` -- it's a false claim made bu dbg-wizard, sorry. Glibc 2.35 is certainly supported, but you need to update to 19541 first
3) `Php version 8.1.2 is not supported by this product` -- that's correct, 19.5 does not support php-8.1. You will need new version of PhpED when it's released. Currently it's in beta testing.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Error checking php installation using wizard
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic