NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debugging password protected websites


Joined: 27 Nov 2009
Posts: 56
Reply with quote
Kept on getting the following message: Failed to start debug session. It's recommended to run project settings wizard and check installation of php and debugger..
Completed the wizard and no issues. Then, instead of step debug, I run, and find the page is not authorized. When doing the wizard, I provide the httpd username/password, but it doesn't stick.
My /etc/httpd/conf/httpd.conf virtual host includes the following.

AuthType Basic
AuthName "Restricted Content"
AuthUserFile /etc/httpd/.htpasswd
Require valid-user

How can I debug Apache password protected page?

Thanks
View user's profileFind all posts by NotionCommotionSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
IDE can't "stick". What can stick is your browser. You can either use "save password" in your browser or use php session-based authentication, not Apache's one. In the first case you'd better switch to external browsers as the embedded ones have slightly limited functionality -- there is no standard menus and dialogs to manage saved passwords.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugging password protected websites
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic