NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debugger stopping at the wrong line after heredoc


Joined: 23 Jun 2008
Posts: 13
Reply with quote
hi, i've noticed an odd bug with debugger (or ide, not sure)
As you can see from screenshot below if there is a heredock block present in the code, phped jump over one row. Infact after row 8 debugger will position itself at the row number 14 in the ide, but it will be on the row number 13 in code execution. it can become very irritating since it's quite difficult to understand after while what is being executed Neutral



Is it solvable in some way or i have to wait for bugfix? Thanks.
View user's profileFind all posts by AlekcSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
Strange, this is working fine for me. The little blue dots in the gutter (in your screenshot) indicate executable lines and line 13 is clearly not being shown as executable (confirming the problem).

Are you perhaps debugging a remote script with the local copy of the script and its remote copy not in sync?

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 23 Jun 2008
Posts: 13
Reply with quote
Indeed.
Script on the server and local side are the same (with my settings every time i save file it's uploaded automaticaly on the server.) Anyway, i've tried it at home and haven't found any problem, i suppose that it's time to reinstall phped on my workstation at work....
View user's profileFind all posts by AlekcSend private message


Joined: 23 Jun 2008
Posts: 13
Reply with quote
Hmm, i've done some tests. It seems to be a server side issue. Since i don't have any problem if testing the script in local or on other servers...

Dbg version is the same on 2 servers, the only difference is that server A (which is working in wrong way) is Ubuntu 6.06lts, php 5.1.2 and server B (which is working correctly) is ubuntu 8.04 LTS and PHP Version 5.2.4-2ubuntu5.3.
View user's profileFind all posts by AlekcSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
It's a known bug in php when HEREDOCs are used. If you make an error for example on 14th line, you'll see line#15 in the error message.

This bug was fixed many times and seems there are always developers in PHP Group who constantly make regression. That's why the bug existed in php-4.3, then was fixed in early 4.4, then re-appeared in later 4.4 and in 5.0, then was fixed in 5.1 and may happen once again in quite new 5.2 but not under all platforms... Go figure.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugger stopping at the wrong line after heredoc
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic