NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debug HTTPS on SRV


Joined: 09 Jun 2018
Posts: 1
Reply with quote
Debugger fails navigate to https://localhost/index.php. http://localhost:8080/index.php works.
Using local SRV WEB server.

Receiving output error:

"Can’t reach this page
Make sure the web address https://localhost is correct"

IDE log records: "IDE Failed to navigate to URL: https://localhost/index.php"

On which port SRV listens HTTPS traffic and how to configure it?
View user's profileFind all posts by markomannikSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7878
Reply with quote
SRV server does not support SSL at all. There are two problems. First is relatively simple -- adding support for SSL protocol itself. The second, I think, has no practical solution at all -- you need SSL certificate, or your browsers will reject working with it. Purchasing your very own certificate just to develop local project seems over-killing. At the same time, if you already have a certificate for your desktop, you can easily install TechPlatform, a free product or any other free Apache or nginx server and configure certificate with it. SRV is not the only server PhpED works with.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debug HTTPS on SRV
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic