NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
dbg-2.11.23 (4.3.3RC1) with php 4.3.3, does it work?


Joined: 25 Apr 2004
Posts: 3
Reply with quote
3rd party web server mode..., server root, root and root URL set.

phpinfo() returns like everything is okay,

but when i try to debug run script remotely from PHPEd, i get "failed to start debugger session (timeout), please verify the debugger module is installed on the server that corresponds to ... URL ...."

firewall is definitely not a problem, because I disabled it. Also tried to telnet from server machine to client, works.

Client machine DBG listener on port 7869 is up.

phpinfo output:

Version 2.11.23
Linked as a shared library.
Profiler compiled, enabled

Directive Local Value Master Value
debugger.enable_session_cookie On On
debugger.enabled On On
debugger.fail_silently On On
debugger.ignore_nops Off Off
debugger.JIT_enabled On On
debugger.JIT_host 192.168.148.1 192.168.148.1
debugger.JIT_level 3 3
debugger.JIT_port 7869 7869
debugger.profiler_enabled On On
debugger.session_nocache On On
debugger.timeout_seconds 300 300

By the way, Linux Apache server / PHP 4.3.3 is installed on VMWare Guest machine. VMWare host is Windows 2000. I really believe it's because of versions mismatch (4.3.3.RC1.so and 4.3.3 php), but I'm not sure. Can someone here confirm it?
View user's profileFind all posts by pycSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Please read FAQ:
http://forum.nusphere.com/howto-install-debugger-module-t576.html
and
http://forum.nusphere.com/tip-troubleshooting-debugger-communications-t579.html
View user's profileFind all posts by dmitriSend private messageVisit poster's website
dbg-2.11.23 (4.3.3RC1) with php 4.3.3, does it work?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic