NuSphere Forums Forum Index
NuSphere Forums
Reply to topic


Joined: 31 Jul 2008
Posts: 17
Location: Basingstoke, UK
Reply with quote
Blizz wrote:
As for the / shortcut, Ctrl+Shift+/ is already assigned to "Add/remove multiline comment" by default and that works fine.
I have no problems assigned a modifier key + / here as a shortcut.

I'm currently evaluating PhpED with a view to switching to it from Zend Studio 5.5.1, and found that Ctrl+/ and Ctrl+Shift+/ were bound to nothing by default and can't be bound to anything. When I attempt to add either of these combinations as a shortcut for "Add/remove line comment" or "Add/remove multiline comment" it just doesn't work. Holding ctrl and pressing / in the shortcut box does nothing, and typing "Ctrl+/" manually gives me an error dialog:
Code:
---------------------------
Error
---------------------------
"Ctrl+/" is not a valid shortcut sequence.
Consider the following examples Ctrl+Alt+Shift+I or Alt+F10 or Shift+Ins
---------------------------
OK   
---------------------------


This is a shame, as it's one of only two problems I've found with PhpEd that remain unresolved, so if anyone can help me get that solved, I would be very grateful.
View user's profileFind all posts by Lord d'EathSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
you must be joking Smile
The shortcuts are used by default for these commands, see screenshots below:



_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Jul 2008
Posts: 17
Location: Basingstoke, UK
Reply with quote
I still can't get it to work. On my original install of PhpED (on a machine running Windows Vista), this is the default set of editor shortcuts:


The edit menu on that machine looks like this:


I also tried upgrading my trial from 5.2 to 5.5, but the default shortcut was still blank.

So I then installed the 5.5 trial on my Windows XP laptop, but Ctrl+/ still didn't do comments:



And those last two screenshots were from a totally fresh install, on a machine that had never seen PhpED before, and I had not touched any settings in PhpED - merely loaded it, drag-drop'd a .php file into the editor, then loaded the settings to get the screenshots.
View user's profileFind all posts by Lord d'EathSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
This makes sense. Trial version is not intended for any kind of updates.

Anyway, I didn't check the shortcuts under non-english Vista (which is full of bugs anyway). Feel free to ask MS why shortcuts that worked fine under XP stopped working under Vista.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Jul 2008
Posts: 17
Location: Basingstoke, UK
Reply with quote
dmitri wrote:
This makes sense. Trial version is not intended for any kind of updates.

How does that affect the fact that my fresh install of the trial didn't have that shortcut set? None if it worked on fresh installs - I only mentioned installing the update to see if it was possibly a bug that was fixed between 5.2 and 5.5.

dmitri wrote:
Anyway, I didn't check the shortcuts under non-english Vista (which is full of bugs anyway). Feel free to ask MS why shortcuts that worked fine under XP stopped working under Vista.

I'm running an English version of Vista, plus I don't have the shortcuts working under XP, either, so it doesn't appear to be a Vista-specific bug.
View user's profileFind all posts by Lord d'EathSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Quote:
I'm running an English version of Vista

I think what you have as default locale is "English Uk" rather than "English US" and it makes big difference. I'd highly appreciate if you try English US (see regional settings in the control panel, including ones on the ADvanced tab where locale is set for all applications including "non-unicode" ones, then reboot and check if the problem is fixed with this simple change.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Jul 2008
Posts: 17
Location: Basingstoke, UK
Reply with quote
Yes, okay, that fixed it Smile I often forget that there's a difference between UK English and US English for Windows, since we still have US spellings everywhere.

Anyway, I can't live with my keyboard and entire OS set to US English, so is a fix for this possible? Smile
View user's profileFind all posts by Lord d'EathSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
I have the same problem (missing Ctrl+/ and Ctrl+Shift+/) with the keyboard locale set to Canada. After changing to English (United States) -US the comment options became available again.

This was not a problem in PhpED 5.2; it is new in 5.5. I am using Windows Vista Business (32bit).

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 13 Jun 2004
Posts: 25
Reply with quote
I posted something on this 2 years ago, I'm surprised it's still an issue.

Would be nice to not have to to change locale each time I upgrade.

I can confirm that a *temporary* locale change in Vista Ultimate 64Bit does the trick when wanting to use / in shortcuts, no reboot needed or even restart of phped.
View user's profileFind all posts by bealersSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Quote:
Anyway, I can't live with my keyboard and entire OS set to US English, so is a fix for this possible?

Fix for this should be done at the OS level that we can't do.
We did our best to find a workaround for the UK (and some other keyboard layouts) but could not do so. Later I'll post a code snapshot that fails and causes Ctrl+/ to be considered as "non existant" shortcut while UK layout is in effect.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
Dmitri, since I am using the US keyboard layout at all times, I find your comment confusing.

The following works:
* English (United States)
* Keyboard: US

The following does not work:
* English (Canada)
* Keyboard: US

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Code:
I find your comment confusing


It does not matter that windows showed "Keboard: US" on the screen. What I meant is keyboard layout returned by GetKeyboardLayout() windows API function. Well, it showed Canada/US? then it's different US than US in US/US because it works differently and I have no workaround at the moment, but I'll try to find.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Ctrl+/ shortcut
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic