NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
CSS not loaded with HTML


Joined: 15 Sep 2018
Posts: 4
Reply with quote
Running a scipt that parse out html ARE NOT Showing output with styles added

It have worked for over 2 years now it simple stop working...

using SRV (local)
PHPed version 19034 on window 10

i am going back to v18 ...NOT Working either
View user's profileFind all posts by rhansenSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Srv does never not snoop into your html.
Check srv log on the log tab. If you see HTTP/404, you need to figure out what's up. It's also possible that there is no HTTP/200 either and browser gets HTML from its cache.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 15 Sep 2018
Posts: 4
Reply with quote
the are HTTP/200 (in SRV log) on html/php file and css file

The border style from css file is added to html output ..the rest gone
View user's profileFind all posts by rhansenSend private message


Joined: 15 Sep 2018
Posts: 4
Reply with quote
i tested html output and css (stylesheet) on FIDDLE(online) it show the correct layout with all styles

PREVIEW of html show the correct output .....
RUN script is not showing output with styles added

have try with embedded browser and external browser in PHPed settings nothing works Evil or Very Mad
View user's profileFind all posts by rhansenSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Is there chance that you passed css through php interpreter? Perhaps that's the easiest way to shoot in leg -- because browser (running on the client) expects certain content type for CSS streams returned by the server, while PHP interpreter, if Content-Type header is not set by underlying script (your CSS is the script in this case), it will add HTML content type. That's how PHP works.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 15 Sep 2018
Posts: 4
Reply with quote
ty for your help

but something has change
.... i will not spend more time on it
View user's profileFind all posts by rhansenSend private message
CSS not loaded with HTML
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic