NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
cool product, but have a few questions


Joined: 16 Jan 2005
Posts: 2
Reply with quote
I've just spent the whole weekend trying to get apache+php+ssl going on windows and still couldn't get it done til i tried out this product. Got it going in 5 seconds. wow.

How can I specify that everything in the root be https ? Also, how can I setup password protected folders in the web site's root folder?

Last question. Will Tomcat work with this setup? I need to support jsp pages.
View user's profileFind all posts by wbuschauSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
If it does not requre any 3rd party apache modules it will work smoothly. If it does you have to compile them from the sources using EAPI (see mod_ssl site for details).

If you want to disable non-https site you may want to comment out non-https virtual hosts. See httpd.conf. Please note that with host-based virtual hosts you can run only one HTTPS site. This limitation is because of mod_ssl itself. See their site for the details.

Password protected folders can be set up easily. See admin area which requires password. See statements like below in the conf:
AuthType Basic
AuthName "Admin Site Access"
AuthUserFile "logs/passwd_tp"
Require user adminmaster
View user's profileFind all posts by dmitriSend private messageVisit poster's website
cool product, but have a few questions
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic