NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Connection to client address XXXX is not allowed


Joined: 15 Nov 2007
Posts: 3
Reply with quote
I've been trying almost all day to try to get PHPED Debugger to work on my new dedicated server. I have took screenshots of everything and how I setup, and connected below, its very easy to follow. I just cannot connect, on the putty screen, I try to setup a SSH tunnel, I run the command, and then do the netstat, and you can see. Any help? I hope pictures make it a 1000x easier, thanks so much.


PHP.INI CONFIG


SUCCESSFULLY INSTALLED



PHPED SETTINGS


PHP PROJECT PROPERTIES


TRY TO MAKE SSH TUNNELING AND DISPLAY NETSTAT CONFIRMATION


FIREFOX SETTINGS


ERROR!!!!!



--

I pretty much did everything in this order, when I try to connect and do it. I hope this helps alot with he pictures, ideas?
View user's profileFind all posts by kazisdamanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
You requested server to start debugging with client IP which is not in the debugger's hosts_allow. That's what "connect to client address xxxx is not allowed" means.
In case of tunnel, you need to use tunnel's far end point, that is in most cases localhost. In this case, put localhost and 127.0.0.1 into hosts_allow and do the same in the toolbar settings (see Machine client host).
BTW, it would start w/o problems if you tried from the IDE, w/o toolbar.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
Dmitri is right. In the DBG toolbar options you need to set Machine client host to localhost.

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 15 Nov 2007
Posts: 3
Reply with quote
#1 Ok I modified my PHP.ini to:

Code:
 extension=dbg.so-5.2.x
[debugger]
debugger.hosts_allow=localhost 127.0.0.1
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16


#2 And set my firefox toolbar machine client host to: localhost

---------------

Whenever I try to run phpdebugger from the toolbar, it just loads loads and loads, and never connects succesfully, no error, just loads?
When I try to run the debugger for the IDE, it times out?

*waiting for debug session*
*failed to start debugger session on server (timeout)*

Any ideas on this?
View user's profileFind all posts by kazisdamanSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
I am not sure of the format for specifying multiple hosts for debugger.hosts_allow. For example, is a space between the entries valid, or should it perhaps be a comma? On my server, I have one entry, namely localhost:
Code:
debugger.hosts_allow=localhost


Maybe that will help? Wink

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
"timeout" means that you did not run ssh tunnel at the moment or you ran it on different port than requested in the URL. You may want to check your server to see if 127.0.0.1/7869 is in listening state and corresponding process is sshd. If you don't see it, check ssh command line arguments.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[resolved] Connection to client address XXXX is not allowed
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic