NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
code completion / extra newline


Joined: 25 May 2004
Posts: 8
Reply with quote
I'm evaluating PhpEd... Great editor!

The only 2 things bugging me:

1.
I didn't find a way to disable automatic code completion and tooltips BUT to be able to show them *when I need them*.

On a lot of editors, you have to press CTRL-SPACE to show the functions/methods and CTRL-SHIFT-SPACE to show the parameters of a function/method.

2.
I'm working on a windows XP platform and my webhosting is on a Linux platform.

I'm not 100% sure how to reproduce this problem but if I have a ".php" file on the linux side and I download it on my windows machine with FTP (using CuteFTP, not the internal PhpEd FTP system) and that I open the file with phpEd, each newline becomes TWO newlines...

Ex:

$test1 = 1 ;
$test2 = 2 ;
$test3 = 3 ;

becomes:

$test1 = 1 ;

$test2 = 2 ;

$test3 = 3 ;


Thanks for the help.
I'm considering buying your product.

Y.
View user's profileFind all posts by yomanfuSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Quote:
I didn't find a way to disable automatic code completion and tooltips

tools->Settings -> Code Insight tab, uncheck "enabled" in Code Completion group and "enabled" in Tooltips group.
Ctrl-Space and Ctrl-Shift-Space will continue work and show Code Completion and Code Tooltips respectively.

Quote:
...that I open the file with phpEd, each newline becomes TWO newlines

It's not a PHPED problem. You Linux ftp server or ftp client (CuteFTP) treats php files as ascii and converts \r to \n. Make sure you have set "binary" transfer mode in your FTP client. If it does not help, you have to either convert your files to Unix format (PhpED->File->Save As->File Format) or install another FTP daemon.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 25 May 2004
Posts: 8
Reply with quote
ddmitrie wrote:
Quote:
I didn't find a way to disable automatic code completion and tooltips

tools->Settings -> Code Insight tab, uncheck "enabled" in Code Completion group and "enabled" in Tooltips group.
Ctrl-Space and Ctrl-Shift-Space will continue work and show Code Completion and Code Tooltips respectively.


Doesn't work for me. When I unckeck "Enabled" for "Code Completion" and "Tooltips", the keyboard keys don't work!



ddmitrie wrote:
Quote:
...that I open the file with phpEd, each newline becomes TWO newlines

It's not a PHPED problem. You Linux ftp server or ftp client (CuteFTP) treats php files as ascii and converts \r to \n. Make sure you have set "binary" transfer mode in your FTP client. If it does not help, you have to either convert your files to Unix format (PhpED->File->Save As->File Format) or install another FTP daemon.


Thanks, I'll try that.
View user's profileFind all posts by yomanfuSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Quote:
Doesn't work for me. When I unckeck "Enabled" for "Code Completion" and "Tooltips", the keyboard keys don't work!


Make sure you talk about phped 3.3.1
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 25 May 2004
Posts: 8
Reply with quote
ddmitrie wrote:
Quote:
Doesn't work for me. When I unckeck "Enabled" for "Code Completion" and "Tooltips", the keyboard keys don't work!


Make sure you talk about phped 3.3.1


It's 3.3 ... I'll try with 3.3.1. Thanks.


Last question:

Is there a way to NOT be able to click anywhere on the editor pane?

I mean:

If there is no characters on a line (and no whitespaces, no tabs), I'd like the cursor to appear at the beginning of that line where ever I click on it.
View user's profileFind all posts by yomanfuSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Quote:
If there is no characters on a line (and no whitespaces, no tabs), I'd like the cursor to appear at the beginning of that line where ever I click on it.

uncheck "cursor beyound the end of line" in the editor settings.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 25 May 2004
Posts: 8
Reply with quote
ddmitrie wrote:
Quote:
If there is no characters on a line (and no whitespaces, no tabs), I'd like the cursor to appear at the beginning of that line where ever I click on it.

uncheck "cursor beyound the end of line" in the editor settings.


Thanks again.
View user's profileFind all posts by yomanfuSend private message
code completion / extra newline
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic