NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Can't Install DBG Extension for PHP?


Joined: 12 May 2009
Posts: 13
Reply with quote
Wow, talk about frustrating. I can't for the life of me, get dbg-php-5.3.dll to load for me. I'm running Apache 2.2 and PHP 5.3 (VC6, Thread Safe) on Windows 7. I'm tried loading it as an ordinary extension and as a zend_extension, but to no avail. I've got this to work in the past on earlier versions of PHP and Windows, so I have a feeling either dbg-php-5.3.dll isn't actually compatible with PHP 5.3 (VC6, Thread Safe), or isn't compatible with Windows 7.

Before my blood boils over in frustration, can anyone please shed some light. I've already spent WAAAY too much time on what should be a 2 minute job.

Thanks
View user's profileFind all posts by WardropSend private message


Joined: 19 Apr 2009
Posts: 9
Location: Guelph, ON Canada
Reply with quote
I've got exactly the same problem, the only difference being that I'm running on Windows XP. Dimitri posted a response to another thread about something changing in PHP 5.3 in the last few days and I wonder if this has any relevance to this problem? Is anyone else having this issue?
View user's profileFind all posts by JCookSend private message


Joined: 12 May 2009
Posts: 13
Reply with quote
JCook wrote:
I've got exactly the same problem, the only difference being that I'm running on Windows XP.


That at least rules out Windows 7 as the problem for me then. I seem to be experiencing problems loading some other PHP extensions also, namely, database extensions such as Microsofts new MSSQL driver (http://sql2k5php.codeplex.com/) and the Postgres PDO driver.
View user's profileFind all posts by WardropSend private message


Joined: 15 Feb 2007
Posts: 6
Reply with quote
I am on Apache 2.2.11 and PHP 3.0, both installed on XP Pro SP3 Polish version and I am experiencing similar problem. I downloaded trial of PHPed 5.8. As before with PHP 5.2.x and PHPEd 5.5 Std, now I copied dbg-php-5.3.dll to PHP ext directory and changed respective entry in php.ini. Nothing. Than I tried with dbg-php-5.2.dll. Nothing. Neither of debugger DLLs from PHPEd 5.8 version installs. When I change PHP back to 5.2.10 or to 5.2.9-2, dbg-php-5.2.dll installs while dbg-php-5.3.dll still does not. Where do I go wrong? Or perhaps there is a bug inside the debugger? Or it's a problem with PHP 5.3 release? Does anybody has any clue?

I wanted to upgrade my PHPEd 5.5 Std to 5.8 Std, but in this situation it would be a loss of money - I cannot debug when working with PHP 5.3 for the debugger does not install.

tia
View user's profileFind all posts by embeerSend private message


Joined: 19 Apr 2009
Posts: 9
Location: Guelph, ON Canada
Reply with quote
I've just installed build 5815 of PHPED and it seems to have fixed this problem. To get the DBG module to work I had to install it as an extension (extension=dbg-php-5.3.dll in php.ini) and not a zend_extension. All seems to work perfectly again now though.
View user's profileFind all posts by JCookSend private message


Joined: 15 Feb 2007
Posts: 6
Reply with quote
JCook wrote:
I've just installed build 5815 of PHPED and it seems to have fixed this problem. To get the DBG module to work I had to install it as an extension (extension=dbg-php-5.3.dll in php.ini) and not a zend_extension. All seems to work perfectly again now though.


I confirm what JCook wrote - with built 5815 which contains debugger ver. 3.8.1 the described problem disappeared.
View user's profileFind all posts by embeerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Quote:
the described problem disappeared


The described problem did not even appear! Smile At least, it's definitely not our problem.
In fact, phped 5.8 was released before php 5.3. We did not know that they will change API number during RC tests, it's a very uncommon practice. Products entered to feature freeze should not change the API ID.
In short, the debugger modules compiled at the moment remained compatible with php 5.3RC3 and only.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 19 Apr 2009
Posts: 9
Location: Guelph, ON Canada
Reply with quote
Thanks Dimitri. I'm just glad it's working again! Smile
View user's profileFind all posts by JCookSend private message


Joined: 12 May 2009
Posts: 13
Reply with quote
Awesome, this fixed my problem. You're forgiven considering it wasn't your faulty Smile
View user's profileFind all posts by WardropSend private message


Joined: 15 Feb 2007
Posts: 6
Reply with quote
dmitri wrote:
Quote:
the described problem disappeared


The described problem did not even appear! Smile At least, it's definitely not our problem.
In fact, phped 5.8 was released before php 5.3. We did not know that they will change API number during RC tests, it's a very uncommon practice. Products entered to feature freeze should not change the API ID.
In short, the debugger modules compiled at the moment remained compatible with php 5.3RC3 and only.


Thanks for your answer. It made me ask this question:

Can we expect that if PHP development team corrects for some reasons the API ID back to the old one, you will than recompile the debugger? It's important for eventual users of PHPEd 5.8.x

tia

Marek
View user's profileFind all posts by embeerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Quote:
Can we expect that if PHP development team corrects for some reasons the API ID back to the old one


After the release? They did not do this in the past. But who knows.
In fact, changing API ID brings nothing wrong. If for one of the bugs in php that have to change some important structures used in the API, they have to change the ID. If they change the structures without changing the ID, the extensions compiled with old API will be binary-incompatible with new code and most probably will crash. So it's safer not to load the extension at all. In other words changing the ID is a kind of protection.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[resolved] Can't Install DBG Extension for PHP?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic