NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
auto-close quotes in comments


Joined: 26 May 2007
Posts: 15
Reply with quote
I have it enabled to automatically close quotes/brackets, but it's annoying with the quotes when I may use apostrophes in comments - it wants to close it!

Obviously I am in a comment.. shouldn't it be disabled when within a comment?
View user's profileFind all posts by Kaitlyn2004Send private message


Joined: 31 Jul 2008
Posts: 17
Location: Basingstoke, UK
Reply with quote
I'd like to second this. Auto-balancing of brackets/quotes can be very frustrating at times (and other IDEs are much less annoying in that regard) but it's most obviously broken inside comments.

Code:
// Please don't balance that apostrophe

shouldn't result in:
Code:
// Please don't balance that apostrophe'
View user's profileFind all posts by Lord d'EathSend private message


Joined: 20 Jul 2009
Posts: 9
Reply with quote
And the motion carries. I like this when coding but having it occur in comments is just plain annoying.
View user's profileFind all posts by squ3lchSend private message
Veteran

Joined: 22 May 2008
Posts: 141
Reply with quote
I don't use auto-balancing anymore, but I agree.
View user's profileFind all posts by simshaunSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8246
Reply with quote
I'd highly appreciate if you describe in details what logic behind this feature would work better for you.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 26 May 2007
Posts: 15
Reply with quote
Once you are inside a comment, things like autoclosing should not be active. It makes no sense
View user's profileFind all posts by Kaitlyn2004Send private message


Joined: 31 Jul 2008
Posts: 17
Location: Basingstoke, UK
Reply with quote
dmitri wrote:
I'd highly appreciate if you describe in details what logic behind this feature would work better for you.

Simple: when typing inside a comment, don't automatically close quotes, brackets, etc. All of these characters are automatically being closed for me when inside a comment: ', ", {, [, (.

While the auto-closing of those characters is very useful while writing code, it's very frustrating when typing a comment, especially since comments often contain apostrophes for contractions (don't, can't, etc.), where you really don't want a second apostrophe left at the end of the comment. As I mentioned above, if you were to type:
Code:
// ' " ( [ { foo

PhpED would automatically insert extra characters, resulting in:
Code:
// ' " ( [ { foo}])"'

And then you have to go and delete the superfluous characters once you've finished writing the comment. It's a waste of time and very inconvenient.
View user's profileFind all posts by Lord d'EathSend private message


Joined: 24 Jan 2008
Posts: 26
Reply with quote
I second the motion... I hate this too.

It's pretty much the only reason I have this feature turned off, it bugs the hell out of me!

As the thread owner said, when in a comment or inside a string, the IDE should NOT auto-close anything in fact. The same problem happens with brackets and parenthesis too.
View user's profileFind all posts by ygirouardSend private message


Joined: 26 May 2007
Posts: 15
Reply with quote
I'm disappointed that nusphere released a new version and this was still not addressed.
View user's profileFind all posts by Kaitlyn2004Send private message


Joined: 24 Jan 2008
Posts: 26
Reply with quote
Kaitlyn2004 wrote:
I'm disappointed that nusphere released a new version and this was still not addressed.


Me too... it's a pretty annoying problem!
View user's profileFind all posts by ygirouardSend private message
auto-close quotes in comments
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic