NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Associated PHPEd to files with no extension


Joined: 16 Jan 2004
Posts: 6
Reply with quote
How do I associate a file that doesn't have an extension to be color coded as PHP? My configuration under Tools -> File Associations is:

*.inc;*.inc4;*.inc5;*.php;*.php3;*.php5;*.phtml;*

...but that doesn't work.

I would like to do this to create "friendly URL's" and using forcetype in Apache, I can accomplish this much simpler than ZF type rewrite rules.

I have seen a couple of other posts on this topic but no resolution. Please help. (it used to work in previous versions of PHPed but doesn't now.)

Thanks,
View user's profileFind all posts by jthomeSend private message
Guru master

Joined: 05 Jul 2004
Posts: 660
Location: Belgium
Reply with quote
PhpEd's highlighting is fully based on the extension of the file. Afaik there is no other way to force it to highlight in a specific language.
Can't you temporarily give the file an extension?
View user's profileFind all posts by BlizzSend private messageVisit poster's website


Joined: 16 Jan 2004
Posts: 6
Reply with quote
I thought that's what the File Association setting is supposed to do, highlight files of a certain type. I used to be able to put in *, or *., but that doesn't work anymore. Even putting in just the filename, like "view", doesn't work. I personally think there is something going on with PHPed and the file association that exists on the OS level. The only workaround I've found is to create a symbolic link between the file with a .php extension and one without (example: view.php -> view).

Like I said though, this used to work in previous versions but doesn't anymore.

Thanks for your response.
View user's profileFind all posts by jthomeSend private message


Joined: 06 Oct 2010
Posts: 2
Reply with quote
To anyone that is looking to have files with no extension recognized as php:

I migrated operating systems to Windows 8 - and at the same time upgraded to the latest PhpED - so really was frustrated that my no-extension files no longer syntax highlighted. (I moved all my old roaming/nusphere data to the new OS)

I looked here and found this thread where the OP said adding * didn't work. I'm sure in my various attempts to edit associations, it didn't work for me.

But I found this thread:

http://forum.nusphere.com/how-do-i-make-phped-recognize-files-without-php-as-php-t3229.html?highlight=associate

So just tried it again and it DID work. So persevere lol
View user's profileFind all posts by vitalviralSend private message
Associated PHPEd to files with no extension
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic