NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Any one experiencing this problem,


Joined: 29 Sep 2010
Posts: 3
Location: UK
Reply with quote
I'm currently waiting a response from Support at NuSphere, but wondering if anyone else has this problem.

The problem is encoded pages are crashing the apache server.

I've located the source of the problem, but don't understand why it is crashing apache.

The encoded file crashes on this line

list($good,$data)=check_company_and_return_dbname($dbc,$_POST['company']);
If I carry out the list function on the next line it works.

$ret=check_company_and_return_dbname($dbc,$_POST['company']);
list($good,$data)=$ret;

Anyone shed any light???

cheers

Nick
View user's profileFind all posts by nickmercurySend private message


Joined: 29 Sep 2010
Posts: 3
Location: UK
Reply with quote
here's a test case, can someone else try it , and see if the encoded version crashed your apache.

[code]
<?php
function test($a,$b)
{
$a+=$b;
return array(true,$a);
}

list($success,$data)=test(1,2);
echo $data;
?>
[/code]
View user's profileFind all posts by nickmercurySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Tried your code and it didn't expose any problems- encoded script is here http://forum.nusphere.com/sshot/2.gz
Is there any chance that you're using php 5.3.0 or 5.3.1?
They are broken and recommended to avoid.
The first more or less stable version in 5.3 branch is 5.3.4 (and 5.3.7 the latest breaks ABA... so the pre-compiled binraries won't load and therefore it's not recommended either)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Sep 2010
Posts: 3
Location: UK
Reply with quote
I'm running 5.3.2.

I'm not able to upgrade, as I've got hundreds of customers running apache locally on there machines.

You tech support has already asked if I can upgrade my php. GGrrrrr


Cheers

Nick
View user's profileFind all posts by nickmercurySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
> I'm not able to upgrade

I can hardly believe.
Php is not something too hard to upgrade. Upgrading to higher sub-minor version goes very smooth and strightforward. Just try 5.3.16 Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Oct 2012
Posts: 8
Reply with quote
There can be many factors making an update very difficult. For instance I use a virtual server and they loaded Ubuntu 11.04, which is a good enough release. The trouble is PHP is at PHP Version 5.3.5-1ubuntu7.10 . Now if this was a local system and not in use for ecommerce I would simply download the latest and greatest PHP version and have at it. If I deviate from the "officially" sanctioned versions then it becomes a crap shoot as to what other problems I could have and certainly I am on my own for any server support. I live in Thailand and the Server is in the US (somewhere in CA) so it pays to be conservative.

I am having problems, BTW, which is why I am reading the Forums. I'll make a new post with my issues.
View user's profileFind all posts by lonnienSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
The latest is by far not always the best. If you have php-5.3.5 comming with your OS distro - that's okay and I'd stay with it because it's known to work, while 5.3.2 is known to fail.
There are always problems with close-to-zero submitor versions. 5.0.0 didn't work at all (5.0.5 was the first working), 5.1.0 didn't work well (5.1.4 did), 5.2.0 didn't work (5.2.1 did), 5.3.0 didn't work (5.3.5 did) and so forth.
As I know, OS maintainers often supply 2 versions of php -- a bit old and another much older. So you have a chance to try both.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Any one experiencing this problem,
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic