NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
3036 doesn't execute well


Joined: 06 Feb 2008
Posts: 13
Location: zagreb, croatia
Reply with quote
I am trying to encode project old cca 3-4 years writter in 4.2-5.0 era with Nu-Coder 3.0 (Build 3036), using licence and php 5.0 and higher, no obfuscation, no headers. I've tried all possible option combinations but I cannot get this encoded project to run. I cannot encode it with 4.4 setting, but I can with 5.0 v4 gives too much dramatic errors which are not worth of fixing.

Project encodes successfully, with couple of deprecated errors like this (in some libs):
Code:
Strict Standards: var: Deprecated. Please use the public/private/protected modifiers at xxx.php(269)


I am doing encoding in windows 7, and testing on ubuntu with latest phpexpress x84_64 plugin installed.
php on server is PHP 5.3.2-1ubuntu4.10 with Suhosin-Patch
there are no other accelerators or optimizers on the system

The errors seen in apache error.log are always the same - complaining that some methods from some classes do not exist. That's hardly likely because those classes are core classes and they are loaded and executet much higher in execution chain. All that lead me to believe that project is executed by php/phpexpress partialy.

I can make the project run again if I replace half of it with non encoded files, but that's just something I tried to avoid by encoding files in first place.

Thanks in advance!
View user's profileFind all posts by sevenSend private messageVisit poster's websiteICQ Number
Re: Project encodes successfully but doesn't execute well
Site Admin

Joined: 13 Jul 2003
Posts: 7826
Reply with quote
seven wrote:
I am trying to encode project old cca 3-4 years writter in 4.2-5.0 era with Nu-Coder 3.0 (Build 3036), using licence and php 5.0 and higher/
...
Code:
Strict Standards: var: Deprecated. Please use the public/private/protected modifiers at xxx.php(269)



hmm. Looks like you miss something. In fact you'd get no E_STRICT warnings if you used php 5.0 rules. It works fine with class properties defined as var. Most probably you selected php 5.2 or 5.3 or left over 5.2 by default.

seven wrote:
but I can with 5.0 v4 gives too much dramatic errors which are not worth of fixing.


Encoding for php v4 requires your code to be php v4 compatible.
If you can't run your code (in source form) under php v4, you also can't encode it for php v4 because for compilation it uses php v4.


seven wrote:
I am doing encoding in windows 7, and testing on ubuntu with latest phpexpress x84_64 plugin installed.
php on server is PHP 5.3.2-1ubuntu4.10 with Suhosin-Patch
there are no other accelerators or optimizers on the system

The errors seen in apache error.log are always the same - complaining that some methods from some classes do not exist.


Effectively you told -- "something does not work, do you know what?" The answer is -- no I do not know. What else would I say? If I was aware of the problem, I'd have already fixed it or at least there was an undergoing fix. But no, nobody reported this problem. You can be first. Please prepare suitable test case and submit using http://www.nusphere.com/contact_us form as suggested in the forum rules (see sticky). Meanwhile -- I know for sure that many 1000s really large projects are successfully encoded with nucoder and brought no problems. Hope yours will work fine too.
TIA

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 06 Feb 2008
Posts: 13
Location: zagreb, croatia
Reply with quote
Hi Dmitri,

I know posting problem like this was a long shot.
After trying out different encoding parameters, I managed to encode project (using php 5.0 settings), but now I am facing strange crashes of php which I have no means of debugging.

Syslog shows this:

Quote:
[Tue Feb 28 17:20:40 2012] [notice] child pid 21572 exit signal Segmentation fault (11)
[Tue Feb 28 17:43:31 2012] [notice] child pid 21579 exit signal Bus error (7)


Hope to try latest nucoder soon and check if this will gone away.
View user's profileFind all posts by sevenSend private messageVisit poster's websiteICQ Number
Site Admin

Joined: 13 Jul 2003
Posts: 7826
Reply with quote
If you check changelog for phpexpress you'll find that we've made some fixes toward stability.
Nothing really new that a new version of php can't work stable with an old php extension. Otherwise why would we have made changes in a software that worked stable for long time?

What's important now is that you have to re-encode your project -- with latest version of NuCoder and install the latest build of PhpExpress on your server(s).

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
3036 doesn't execute well
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic